ATMSolutions C02 PRO35 MINI - able to connect on Linux only with sudo, is it intentional? (now with debug log)

EDIT: I succeeded after I used sudo, is it intentional or a hacky workaround?

I have access to a laser, but it is not my own so I am not allowed to flash it etc.

Noone even tried connecting with Linux or Mac.

People succeded with LightBurn and RDWorks on Windows.

Sole remaining ideas:

“is your user profile set up with dialout / tty permissions? If not, LightBurn won’t be able to see the USB connection.”

How can I check this? I see nothing in logs complaining about it, but I also so far failed to check this.

“Port open failed” hint - investigating Search results for 'Port open failed' - LightBurn Software Forum “Something is keeping the port locked - That’s why it’s saying “Port open failed”. It’s trying to connect, and unable to. LightBurn is finding the port properly.”

What I tried:
Automatic detection
I was trying to connect to ATMSolutions C02 PRO35 MINI via USB but LightBurn was unable to detect this device. Device > Find my laser was resulting in getting “Device discovery wizard” with empty device list.
log is at log on automatic detection attempt · GitHub - I see nothing useful there, but it seems that it at least detected something

15:47:15.938  D: Enumerating ports:
15:47:15.978  D: Port: "ttyUSB0"
15:47:15.978  D:       Valid Candidate:  true
15:47:15.978  D:       PID: 24577 VID: 1027
15:47:15.978  D:       Manufacturer: "FTDI"
15:47:15.978  D:       Description: "FT245R USB FIFO"
15:47:15.978  D:       System Loc: "/dev/ttyUSB0"
15:47:15.978  D:       Serial: "AC01LYBY"
15:47:15.978  D: 
15:47:15.978  D: EV: 1019 took 1477444 uS

Laser was sole connected USB device.

dmesg shows device connecting:

[ 2443.532203] usb 1-3: new full-speed USB device number 11 using xhci_hcd
[ 2443.687063] usb 1-3: New USB device found, idVendor=0403, idProduct=6001, bcdDevice= 6.00
[ 2443.687072] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2443.687077] usb 1-3: Product: FT245R USB FIFO
[ 2443.687081] usb 1-3: Manufacturer: FTDI
[ 2443.687084] usb 1-3: SerialNumber: AC01LYBY
[ 2443.695143] ftdi_sio 1-3:1.0: FTDI USB Serial Device converter detected
[ 2443.695231] usb 1-3: Detected FT232RL
[ 2443.696229] usb 1-3: FTDI USB Serial Device converter now attached to ttyUSB0


Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 04f3:22d7 Elan Microelectronics Corp. Touchscreen
Bus 001 Device 003: ID 8087:0a2b Intel Corp. 
Bus 001 Device 002: ID 0c45:6715 Microdia Integrated_Webcam_HD
Bus 001 Device 011: ID 0403:6001 Future Technology Devices International, Ltd FT232 Serial (UART) IC
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo lsinput logs: sudo lsinput.log · GitHub

Manual config.
Field of work: 500 x 300 mm
set rear right to 0, 0

Edit → machine settings
it gives “communication with controller failed”

First time users - welcome! - not useful as what is described there failed for me

I am running
LightBurn 0.9.20, built nie 2020-12-20 @ 01:42
Ubuntu 20.04.2 (Lubuntu to be more specific)

I am not using external hub, I connect USB directly to laptop.
I checked a different working cable.
I did sudo apt-get dist-upgrade
As far as I know I m using latest LightBurn.
I am not really interested in Windows version - I want to buy LightBurn because it has Linux support.

previous attempt Lightburn will not find my Rudia laser
This a new test on a new laptop, also on Linux

So far I failed to get even an useful error

One more idea: LightBurn binary started from command line, automatic detection:

libpng warning: iCCP: known incorrect sRGB profile                                                                                                                                           
"Integrated_Webcam_HD: Integrate" "/dev/video0"                                                                                                                                              
Found port: PID 24577 VID 1027                                                                                                                                                               
Manufacturer: "FTDI"                                                                                                                                                                         
Product: "FT245R USB FIFO" on "ttyUSB0"                                                                                                                                                      
FTDI: Probable Ruida / TopWisdom (possibly GRBL)                                                                                                                                             
sent 8                                                                                                                                                                                                                                                       
waiting for 18                                                                                                                                                                                                                                               
Vend: 7531 Prod: 3                                                                                                                                                                                                                                           
Vend: 1267 Prod: 8919                                                                                                                                                                                                                                        
Vend: 32903 Prod: 2603                                                                                                                                                                                                                                       
Vend: 3141 Prod: 26389                                                                                                                                                                                                                                       
Vend: 1027 Prod: 24577                                                                                                                                                                                                                                       
Vend: 7531 Prod: 2
sudo ./LightBurn                                                                                                                                                                                                     
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'                                                                                                                                                                                   
libpng warning: iCCP: known incorrect sRGB profile                                                                                                                                                                                                           
Couldn't open preferences file for reading                                                                                                                                                                                                                   
"Integrated_Webcam_HD: Integrate" "/dev/video0"                                                                                                                                                                                                              
Couldn't open preferences file for reading                                                                                                                                                                                                                   
QXcbConnection: XCB error: 3 (BadWindow), sequence: 898, resource id: 4218701, major code: 40 (TranslateCoords), minor code: 0                                                                                                                               
Found port: PID 24577 VID 1027                                                                                                                                                                                                                               
Manufacturer: "FTDI"
Product: "FT245R USB FIFO" on "ttyUSB0"
FTDI: Probable Ruida / TopWisdom (possibly GRBL)
Port open succeeded
Vend: 7531 Prod: 3
Manufacturer: Linux 5.4.0-67-generic xhci-hcd Product: xHCI Host Controller Serial: 0000:00:14.0
Vend: 1267 Prod: 8919
Manufacturer: ELAN Product: Touchscreen Serial: 
Vend: 32903 Prod: 2603
Manufacturer:  Product:  Serial: 
Vend: 3141 Prod: 26389
Manufacturer: CN0PYJNXLOG007BAB0H9A01 Product: Integrated_Webcam_HD Serial: 
Vend: 1027 Prod: 24577
Manufacturer: FTDI Product: FT245R USB FIFO Serial: AC01LYBY
Vend: 7531 Prod: 2
Manufacturer: Linux 5.4.0-67-generic xhci-hcd Product: xHCI Host Controller Serial: 0000:00:14.0

now it works (at least laser detection)

Trying to fire up a new Mini Gerbil - #3 by chaoticmind indicates that it is related to dialout permission

at the console just run the command groups
It should print out a list of groups your user is in, if you do not see “dialout” in that group, then run:

sudo usermod -a -G dialout ${USER}

Then reboot.
After that my guess is you will be able to connect to the laser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.