ATMSolutions C02 PRO35 MINI - unable to connect

I visited First time users - welcome! but I was unable to use “Device setup” video. Youtube shows me “Video unavailable, this video is private”

I have access to a laser, but it is not my own so I am not allowed to flash it etc.

Someone else connected to the laser with RDWorks and it worked fine for him.

I was trying to use LightBurn-v0.9.07-x86_64

I was trying to connect to ATMSolutions C02 PRO35 MINI via USB but LightBurn was unable to detect this device. Device > Find my laser was resulting in getting “Device discovery wizard” with empty device list.

I am running Ubuntu 16.04.

The same place has also ATMSolutions CO2 ATMS PRO1016 80 W, but I was not trying connect to this one.


what can I do to connect or collect more useful debug info?

Thank you for bringing the issue of the ‘Device Setup’ video to our attention. We have updated the video but needed to update this link. I have done so and this should be resolved. You can access for here as well: https://www.youtube.com/watch?v=BkNeVjbZncc

I understand you are having issues with LightBurn discovering your setup. You might need to install an FTDI driver. The FTDI driver is needed to communicate with a number of controllers that LightBurn supports. RDWorks has the option to install the driver so it may not be installed yet on your system. Have you run RDWorks from your computer?

You can install the FTDI drivers (used by Ruida) from here: https://www.ftdichip.com/Drivers/VCP.htm

Additionally, have you tried to set up this device manually? You can walk through this process, selecting ‘Ruida’ as the controller and then click-through, answering the remaining questions until complete.

Try these suggestions and let us know your results. We will get you sorted. :slight_smile:

1 Like

No driver install needed on Linux. They are built-in.

1 Like

When you’re connected, what does your USB discovery show?

lsusb

or, for more info, install lsinput

sudo apt-get install input-utils

example:

If you can’t see the device, have a look at dmesg to see if there’s some sort of error preventing the OS recognising the device.

sudo dmesg

  • IOAudioEngine[]::startClient()
  • IOAudioEngine[]::incrementActiveUserClients() - 0
  • IOAudioEngine[]::startAudioEngine(state = 0)
    controlID: 0, coreAudioChannelID = 0 MASTER oldValue 0x13, newValue 0x13
    controlID: 4, coreAudioChannelID = 2 FRONT RIGHT oldValue 0x5F, newValue 0x5F
    controlID: 2, coreAudioChannelID = 1 FRONT LEFT oldValue 0x5F, newValue 0x5F
    ± IOAudioDevice[]::flushAudioControls()
  • IOAudioDevice[]::protectedCompletePowerStateChange() - current = 1 - pending = 2
  • IOAudioDevice[]::protectedCompletePowerStateChange() - current = 2 - pending = 2 returns 0x0
  • IOAudioDevice[]::protectedCompletePowerStateChange() - current = 2 - pending = 2
  • IOAudioDevice[]::protectedCompletePowerStateChange() - current = 2 - pending = 2 returns 0x0
  • IOAudioDevice[]::audioEngineStarting() - numRunningAudioEngines = 0
  • IOAudioDevice[]::audioEngineStarting() - numRunningAudioEngines = 1
    ± IOAudioEngine[]::resetStatusBuffer()
1 Like

Thanks for all help! Laser remains unconnected but I collected some info.

I retested this steps, with no useful result - no devices were detected.

According to https://www.ftdichip.com/Drivers/VCP.htm “All FTDI devices now supported in Ubuntu 11.10, kernel 3.0.0-19” and I have later version.

Yes, but I am unable to “Get position”, “Move to Position” is not resulting in movement etc.

lsusb

Relevant one is apparently

Bus 006 Device 005: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

as it is one that appears/disappears as I plug in and out USB cable.

I can also post full list if useful.

lsinput without sudo fails for me, with sudo shows the same list in both cases and nothing appears to be the laser. I also can post full dump if useful.

sudo dmesg gives

[ 3392.032075] usb 6-1: new full-speed USB device number 10 using uhci_hcd
[ 3392.254091] usb 6-1: New USB device found, idVendor=0403, idProduct=6001
[ 3392.254095] usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3392.254097] usb 6-1: Product: FT245R USB FIFO
[ 3392.254099] usb 6-1: Manufacturer: FTDI
[ 3392.254100] usb 6-1: SerialNumber: AC01LYBY
[ 3392.262162] ftdi_sio 6-1:1.0: FTDI USB Serial Device converter detected
[ 3392.262215] usb 6-1: Detected FT232RL
[ 3392.264667] usb 6-1: FTDI USB Serial Device converter now attached to ttyUSB0q

after connecting laser.

That all looks good - so you’re connecting OK and the OS knows what it is you’re connecting.

So… have you got another laptop or something that you can connect and test?

Have you done the obvious: checked/changed the USB cable; tried connecting via Ethernet; tried a different app; correctly uninstalled and reinstalled LightBurn; checked for system updates; checked for FTDI driver updates?

1 Like

Oh, wait…

You had Bus 6 dev 5, but dmesg is showing Bus 6 dev 1?

Difference is likely caused by trying different USB ports to see whatever something relevant will change. dmesg and lsusb from the same attaching.

dmesg

[ 4718.644082] usb 6-1: new full-speed USB device number 12 using uhci_hcd
[ 4718.863097] usb 6-1: New USB device found, idVendor=0403, idProduct=6001
[ 4718.863100] usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4718.863103] usb 6-1: Product: FT245R USB FIFO
[ 4718.863104] usb 6-1: Manufacturer: FTDI
[ 4718.863106] usb 6-1: SerialNumber: AC01LYBY
[ 4718.871177] ftdi_sio 6-1:1.0: FTDI USB Serial Device converter detected
[ 4718.871226] usb 6-1: Detected FT232RL
[ 4718.873207] usb 6-1: FTDI USB Serial Device converter now attached to ttyUSB0

lsusb

Bus 006 Device 012: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

Weird AF.

If I connect, disconnect and reconnect, the device number only changes if I use a different port and if I go back to the original one, the number goes back in line.

Are you using an external USB hub?

1 Like

I am not using external USB hub, and I went back to a port that was used earlier.

Initially I suspected that there may be something wrong with USB ports. I had weird issues with one specific external HDD refusing to connect on one specific USB port in the past.

At least two other Makerspace users have no trouble, one connecting with Lightburn on Windows, one with rdworks on Windows.

They have a single USB cable for the laser, so I was unable to try alternative ones.

Laser appears to have no Ethernet ports, but supposedly has ability to connect via Wifi. Not sure how connection via wifi works in LightBurn, for now I found Adding Wi-Fi to Ruida RDC6445G that suggest that additional hardware is necessary.

My lightburn is not installed but I redownloaded app image from https://lightburnsoftware.com/pages/trial-version-try-before-you-buy

I will now look also for an alternative, software - though I was happy about lightburn because it works on Linux.

Yes (sudo apt-get update + sudo apt-get dist-upgrade) though maybe it is issue solvable by upgrading to 18 LTS (I am on 16 LTS) that I plan to do anyway.

Ah - that information would have been useful.

When you say “LightBurn was unable to detect the device”, are you trying to use the automatic setup wizard? If so, can you try setting up manually instead? There is some debug logging that can be enabled in LightBurn that might help.

Also, is your user profile set up with dialout / tty permissions? If not, LightBurn won’t be able to see the USB connection.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.