Atomstack P7 laser not burning / firing

My laser just stopped working. I shut it off for the night and came back and it won’t fire.

It runs the whole job with no laser.

Any ideas on settings I should check? I set and reset focus several times.

I have tried every combination of speed power to no avail.

Any ideas?

Check S-value max in Device Settings.
In the console check $30, $31 and $32

These are;
$30 - Max Spindle Speed and should match your S-value max in the Device Settings
$31 - Min Spindle Speed. Should be 0
$32 - Laser Mode. Should be 1

Thanks. Checked all three. All was set as expected. Looks like I might have a faulty module? Ugh.

Do you have a voltmeter?

You can measure the pwm going to the laser module, along with it’s supply voltage.

That should tell you if it’s a controller problem or a laser module issue.


Hi and Thanks.

I do have a voltmeter, but im not sure how to use the thing. I will go watch some basics on you-tube. Can you give me an idea of test point locations I need to focus on? I know this sounds dumb but I am a newbie and don’t want to overlook anything stupid.

No problem… we don’t learn by osmosis…

This is my laser module, you might have to find your to get some kind of reference for your laser module pinout.

Most of these have only three connections. Don’t worry about Temperature.

  1. ground
  2. power
  3. pwm

Yours might or might not have the same pin out.

If you measure from ground to power you should read full supply voltage to the laser.

From ground to pwm, is a ttl signal (0 to 5V) that is used to fire the laser. When it goes high the laser turns on, when low it is off.

You don’t need the laser module powered up, so you can do this from the connector if you wish… For the PWM reading you need to send a job to the machine at a specific power percentage.

Don’t short any of these lines to any other.

With a voltmeter you can measure 50% pwm at about 1/2 of the 5V supply… The percentage power you send it will be a percentage of the 5V supply control. 20% is 1V… 60% would be about 3V… 50% is usually pretty easy.

If you have the supply voltage and a valid pwm, the laser should fire…

Make sense?


Absolutely awesome. Thank you so much for taking the time to help.

I will get on this asap and let ya know what’s what.

No perspiration…

Hang in there…


Hello Again!

I have another issue you may be able to assist me with…?

I purchased the atomstack roller engraver attachment and I am having an issue. The roller comes with two motor cables ( I have tried both in my setup) and the motor just buzzes loudly and the unit vibrates.

I have gone through the rotary setup tool in lightburn, and all I get is this!


Any insight?

Might want to post a screenshot of the rotary gui displayed in Lightburn.

This is usually step/rotation or deg/rotation…

What is that set to?

Screeshots are preferred, I couldn’t read anything on the screen in the video…

For future reference, it’s better to mark the original thread solved, the initial problem here, and start a new thread with the proper information. If this solves your problem, nobody will be able to find it buried down here in this thread…

Maybe @JohnJohn can split it for us…