Auto "home" your laser on startup? - Doesnt exist!

That setting seems to be missing…
Went to

Found my laser
picked upper right for origin - But under it should be the auto-home setting… is not there.

Any help? Just crashed my machine into some steel weights, so I would like to disable homing on startup

Auto-Home is not an option LightBurn controls for the Ruida profile. That option is stored in the controller. This option is available for profiles of a different controller. Could this be your issue? Did you also use LightBurn to control a GCode based system. This is a valid option there.

Screen-grab of GCode profile:

This is from the Ruida setup screen:

On Ruida it’s in the vendor settings, enabled per motor axis at the bottom. It’s not recommended to turn it off, as the machine normally prevents itself from running out of bounds when it’s homed correctly. If you don’t home it, it can’t do that.

I only want to home it when I am sure the bed is clear. IE when I crash the machine I would like to clear things out of the way. I crashed the Z when I was trying to move my Auto Z nipple depressor up a bit for more clearance. I needed to test but I messed up. Then, when I restarted the machine ( after Estop) it Auto homed and was grinding a stuck part along the bed. It was horrible.

That option is not there in Lightburn under Devices. Where do I find it if not there?

I am not sure what option you are referring to.

If you are looking for these vendor settings in LightBurn, go to ‘Edit’→’Machine Settings’. Be very careful what you change in there, write it down first so you can change them back if required, as these are the settings provided from Boss when the system was originally configured. If you are not already familiar with these settings and how they affect the operation of your Boss, you might want to contact them directly for recommendations for adjustment to the current workflow to best fit your needs.

See above - that’s where it is. The ‘Auto Home on Startup’ setting in the initial setup is for GCode systems only.

Pardon my misunderstanding again. I just need to clarify… if I go to the vendor settings and disable x and y home, It crashes when I press the home button. I only want to disable Auto home for when the machine starts up, not to disable the ability for it to go home without crashing. So, the option to disable “Auto home on startup” under “Devices” is only available for G code based machines?

Auto-Home on startup is a switch that tells LightBurn to send the homing command to GCode devices when they connect.

On a DSP controller, the entire process is managed by the controller itself, not LightBurn. If you turn off homing, it turns off the homing on power on behavior. I don’t think I’ve ever tried to home a machine with the homing settings disabled, but that would be a Ruida controller behavior, and not something I have control over.

Ok Thanks for clarifying.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.