Autofocus problem

Hello i wonder if someone can help me, i think this is a settings problem in machine settings on a Ruida 6445G

i have asked for autofocus to be put on one of our machines its one of the first ones we have asked for this.
when i click autofocus, it says press enter to continue, then it comes back with Z bed has no reset.

After speaking with the company we purchased it from they told me autofocus is just manual, it works like limit sensor and stops the bed, you have to move z axis yourself to the limit sensor, for me this is wrong as the bed isnt dropping back down 7mm for the focus.

what i am asking in the machine settings can i set it to autohome the Z axis then for it to drop back 7mm?

thanks in advance

Alan

Is the limit switch on the probe like the one in this video?

This may be worth review:

hello yes i know that i am just asking as i read the machine settings in lightburn and not on the controller itself, and just wondered if anyone had the relevant machine settings to set the controller correctly

thank you and sorry if ive posted in the wrong place

Alan

Russ Sadler makes some great videos… Here are a couple of them on autofocus. They could answer your questions better than I could. Might be worth a few… I think the first is a 2019, leaving the other from 2018…


Good luck

:smile_cat:

ill have a look later at the videos thank you for that,
i still think its a settings issue.

i got told by the “engineer” in China to make sure homing was on the Z axis and home offset was set at 7mm the focus distance, so basically the Z bed homes to the limit trigger which is the autofocus probe, and yes that now works, it goes up and down a couple of times, but then th eZ bed doesnt stop, it heads off downwards to the bottom of the machine right to the bottom instead of staying at 7mm offset, so once i can find out whats causing that in the settings i should be sorted out if any has an idea.

thank you
Alan

Ok well we are getting a bit further.
a friend sent me this video link and i followed it to the letter
Installing Z Axis Focus Sensor on Co2 Laser - CNC Co2 Laser Machine - YouTube at about 8 minutes th econtroller shows the bottom enable laser in th eoff position on the bottom menu box, this is what was causing th ebed to drop to its bottom limit, i turned it off as it was mentioned in the comments that it was doing that.

so the only problem i have now, is after inserting a bit of 3mm scrap under the probe to allow it to move away an extra 3mm above the surface of the substrate the probe is now clicking on (red led inside top) showing its triggered and then th eprobe is supposed to move back down 3mm this is what its not doing so the focus is staying at around 4mm and not 7mm. and also the spring ended part of the probe is still pressing agains the substrate instead of moving away,

TIA

Alan

as the autofocus sensor is just acting as a limit switch on the Z bed , and i know the auto home switch functions to home the bed, is the home offset relevent for the autofocus? should i have this set to the required focus length and then input the distance in mm to move the probe away from the surface of the material?
Thank you
Alan

ok ill try again with this as i have just tried everything, after watching russ sadlers video and see how he sets the offset in the focus menu to get the Z bed to drop away from the autofocus limit switch/sensor it isnt doing it it goes up and down twice but on the second down motion it stays there no matter what offset setting i put in, it doesnt alter from the off switch position even though the controller reports back the correct reading on the controller. example i set it to 7.0mm and the controller reads 6.9mm but the head is still only 1.5mm from the material, so th econtroller thinks th ebed is moving down even though it isnt. anyone any ideas please

Alan