Back with the Same Issue... Lightburn on Mac Cannot Find Laser

Now I’m losing my sh*t. I have orders to get cut and I can’t get the software to find the controller/laser again. Had this issue on Friday and then updated my Mac OS and it connected.
Didn’t use it yesterday and trying for an hour today to get it online and I can’t.

NOTHING changed between connecting Friday and today. I wasn’t even home to use my computer!
This is infuriating.
9.24 is not the magic Mac fix it’s believed to be.

*There’s a woman in a FB forum having this exact issue today, too.

You can always go back to any old version as well. How do I find older versions of LightBurn?

Thanks Steve. Yes, someone let me know going all the way back to 9.20 might work.

MacOS and USB has always been hit or miss. Some people have zero issues, some can’t get a connection. MacOS includes a driver that has known conflicts with the one used by the Ruida, and there’s nothing we can do to fix that.

The best possible option is to buy the $30 Ethernet adapter from Apple and plug a network cable between the Mac and the laser. It takes a little bit of effort to set it up, but it’s more stable and faster.

I will keep poking at the USB connection here to see if I can find anything, but I have four different Macs connected to Ruida controllers, and none of them are having any issues - it’s difficult to fix something I can’t reproduce.

Already attempted to set it up over Ethernet and it didn’t work.

This may help in walking through the setup process. Can you share the details of what you did try?

I already knew my IP address so I skipped the early part and started where I give the Ruida a new IP address and then input it into the Ethernet (hardwired) set up.
We tried it again over WiFi (with guidance from an Aeon tech) and it still doesn’t detect it.

We can help double-check these settings if you post the details.

What do you mean, you tried it over WIFI? Laser wired to an access point, or … ? Ruida controllers don’t have WIFI built in - you have to use a wired connection, or connect through a wireless access point. Running a wire between the Mac and the laser is the most bulletproof way. If you’re using WIFI on the Mac you might actually have to turn it off while running jobs.

If you could tell us how your network is connected, that would help.

How is your Aeon connected to your network? Ethernet cable to a router/switch?

How is your Mac connected to your network? Via wifi to your ethernet router/AP?

What are your Mac wireless settings? Take a snapshot of the System Preferences window, like this:

Screen Shot 2021-04-27 at 6.38.18 PM

Your Aeon has a simple network setup - usually just ethernet IP address and a netmask.

In the case above, with your wireless in the 192.168.1.x range, your setting at the Aeon would be 192.168.1.x net mask 255.255.255.0

You may have a conflict with another IP address. Use LanScan (available from the Apple Store for free) to check all the IP addresses on your network and set your Aeon to an unused one. If you know the DHCP range your router gives out, it will help. You can find that by getting into your router firmware page, but not absolutely necessary.

Rudia networking is bulletproof, and Lightburn over ethernet has been proven to be very reliable.

If you have your networking set up correctly, and you still can’t connect to the Aeon, I would definitely think that you have an IP address conflict. LanScan will highlight that. ‎LanScan on the Mac App Store

Hi All -
Ok, I have to be honest here… I’m getting so many different pieces of advice that I am getting confused.
Many of the things I’ve already attempted I got from reading the forum and following the step-by-step instructions like this one:

As many of them were attempted several days ago, I no longer have screen shots to share or settings to tell you.
As for trying to connect Mac/Lightburn to the laser/controller over WiFi, I was following very specific instructions from the Aeon tech I was working with.

I think my best bet now is to start over. Pretend I didn’t do any of these things.
Can we start from scratch and I say:
I ran a USB from my Mac to my Mira 7 with Ruida controller and manually set it up in Lightburn. But it tells me there is no device found. I did it again with versions 9.20 and 9.24.

What should my next move be?

Shut down and restart the Mac. Does it still do this?

Are you connected to the ‘PC-USB’ port on the Mira? (just checking, as there is also a UDisk port).

Yes, and yes.
I’ve restarted and I am plugged into the PC-USB.

Which version of MacOS are you running? (You said you updated, but I’m looking for specifics)

I am now running Big Sur.