Big Laser Problem

I have an OMTech laser and they can’t help me.
After starting, the laser rattles into the home position. It takes a very long time for the Ruida to initialize and the head always moves back and forth a little bit.
When it’s finished and I press left, the head moves to the right or left.
It’s arbitrary.
Could it be that the board is defective? Please watch the video:

Can you help me?

Did this just start happening?

Check the wires from the controller to the X axis stepper driver and from the driver to the motor. The symptoms suggest the motor is not being driven correctly and a loose / broken wire will do that.

Don’t trust a visual inspection. Get out your screwdriver, remove each wire from its terminal, make sure the ferrule is crimped, verify there’s actually a terminal inside the block, and tighten the wire back in its place.

After verifying the connections, we can look for other problems.

Many thanks for your response.
The problem was a few days ago but OMTech is providing no help or only very slowly. The laser is just 6 weeks old. I don’t know if I can access the cables because of the warranty.
I have already changed the driver and motor. But the problem still exists.

That changes the diagnosis, but does not rule out a bad wire or connection.

You already did that when you replaced the parts. Basically, you’re the technician doing the hand work: learning on the job as you dig into the problem.

Asking again: did this just start happening?

In other words, did the machine ever work correctly?

There is no technician in Germany. They send videos and texts to help and say that the warranty is not violated.

When the laser was delivered the water sensor was defective. After unpacking it worked.
He hasn’t walked for 3-4 days.
In the middle of engraving, the X-axis went crazy and it remains that way to this day.
I’m also so disappointed with the support.
They send a small email every 24 hours.

If I understand correctly: the machine worked for some time after you replaced the water flow sensor, then failed later and has remained in that condition. How long did you use it successfully?

Knowing the history helps figure out what changed.

Ah, but there is: you! OMTech depends on you to make the diagnosis and fix the problem. :grin:

Exactly, after changing the water sensor it ran.
I had to replace the endstop once. The red cap on the sensor was broken off. I had a replacement and installed it and then the laser worked for almost 14 days without any problems.
Now, with the help of a friend, I was able to make a small improvement.
The engine no longer rattles as much, but only in certain situations.
If I now move several times from the far left (1300mm in the display) to the far right (0mm), the laser seems to lose its position and stops where it wants.
It’s hard to explain, so here’s a link to the video: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

It’s cruel with OMTech. I’ll NEVER say it AGAIN!
Just an email with a sentence every 24 hours. No online chat or video chat.

What did you change?

To verify that the Home switch works correctly, please verify:

  • The switch lights up with a ferrous object near the target on the top
  • The switch lights up twice, very briefly, when the laser head goes through the Home sequence when you turn the power on

The controller should have a diagnostic display showing the input signals, similar to this:

Does the LmtX- indicator light up (probably red) when you bring a ferrous object close to the X axis switch?

After you verify the driver / motor wiring and switch operation, then suspicion falls on the acceleration and speed settings for the X axis. If the motor is being driven too fast or accelerated too hard, the rotor will lose synchronization with the Step pulses and can move in either direction at nearly any speed.

Go to Edit → Machine Settings → Vendor Settings → X axis, capture a screen shot of the speed & acceleration values, and include that in your reply. It will look similar to this:

Then we can puzzle over the values …

Yes, the limit switch lights up when I hold a screwdriver to it.
The Y-axis endstop lights when starting, goes off briefly, then comes on again, and is off when the start sequence is complete.
The endstop of the X-axis sometimes does not come on at all or only comes on for a very short time and then goes off.
The interval is longer for the Y axis.
When I check the display, no error is displayed, only when I touch the sensor with the screwdriver does a red light come on.

I still have spare sensors and would install them.
But I don’t know where the 3 cables have to be connected to the Ruida to rule out a cable break.

Errors on the outputs can be a symptom of a bad power supply. When you get errors like that, one of the first things to do is to start measuring supply voltages. You should have at least 24VDC coming from the supply. When you check it without a load it may read 24v but you also need to measure the voltage while there is demand.

I don’t know anything about electronics and have no plan for measuring.

I understand your situation and It would be very dangerous to attempt unless you really understand what you are doing.
This is where having a mate who happens to be an electrician comes in handy.

The home sequence works like this:

  • Fast seek to find the switch
  • Back off to release
  • Slow seek to find the switch again
  • Back off to release

The X axis moves quickly enough that the fast seek barely blink the switch and the slow seek might be a little longer. Judging from your tests, the home switch is working as it should.

All of the X Axis Settings seem reasonable, although the Step length is unusually large.

The stepper driver has a set of DIP switches that determine the motor current and the number of steps per motor revolution:

When you replaced the X axis driver you probably set them to match the old driver. Take a picture of those switches and the data plate on the side of the driver showing the selections, so we can verify the setup.

The switch settings should be the same on the X and Y axis drivers, but check that while you have your head inside the cabinet.

I reinstalled the original driver because it wasn’t defective.
I also found where the end sensor is connected in the Ruida.
In my case, as in your photo, the cable is glued to the plug.
I could remove it but I still have a warranty on it and if I remove it it will be void.
I think I’ll have to continue to worry about the support and if it takes years.

AFAICT, the seller can handle replacing parts, but will be totally useless for figuring out any problems, regardless of any “support” they may claim to provide, and particularly with regard to configuration issues. The more comfortable you get with how your machine works, the better you’ll be at keeping it working in the future.

Also, the longer they can stall you, the more likely it will be that the “warranty” will expire and relieve them of any responsibility. Warranty coverage is different in the EU than in the US, but that’s how they operate.

I regarded my OMTech as a parts kit that closely resembled a functional laser, while realizing I would be responsible for troubleshooting and adjustments. That’s how it worked out in practice and, after two years, I have a good idea how to fix whatever goes wrong.

Folks expecting extensive hand-holding & troubleshooting from the seller seem to be very disappointed in the outcome, as they must then climb a very steep learning curve just to get the machine working after delivery.

Comments & discussion on this forum show machines can arrive with gross mechanical problems, completely incorrect configurations, and poor alignment. Unfortunately, an assumption that the machine was set up correctly before it went into the shipping crate is demonstrably incorrect.

Think of this as an opportunity to learn many new things … :grin:

This is a quick video of checking the switches.… Sounds like you’ve done this, but I’m not clear about it.


OMTech just wrote and “THINKS” the motor is defective. A replacement engine would take 2-3 weeks due to the New Year.
If the replacement doesn’t fix the problem, they would replace the machine.
I replied that I would take the exchange machine. I don’t want to wait that long.

Obviously it’s NOT the engine. I think (as a layman) at Endstop or Ruida.

The sensor works. I replaced it anyway. But it didn’t bring any help.