BSL Boards/SeaCad

I own a galvo laser that has a BSL DBK21B board from what i know and runs on seacad software. Originally designed for iphone backglass. Seacad is just a bad software and from what i can see, lightburn still hasn’t implemented support for these lasers. What can i do to get lightburn running this machine. Ive seen some people change out boards but im not sure what to get and what will work with light burn.

1 Like

I bought the laser machine from Rewa

Welcome Jess, and the timing of your question is perfect. :slight_smile:

We have been working on BSL support for some time now and have moved these efforts forward to a point where we can start to share beta for this upcoming release. If you are willing, have a look at this:

Hey, does this mean the Atomstack M4 will work too?

Interesting question!
@johnjohn @Rick might clarify

We don’t know all compatibility just yet, hence the beta - give it a try!

1 Like

Okay, I’ve given it a try.
1: Version 1.7 is a must, as seen above: BSL and XTool Beta - Google Drive
2: Lightburn finds the Laser and Importing the SeaCAD config worked out.
3: However, the laser goes crazy as soon as you create something on the workspace, it starts lasering non-stop and can’t be halted without powering off.
The settings from SeaCAD seem to match up in LightBurn as far as I can tell.
Any Ideas?

Brian Lee has made a quick little guide that may be useful for you here - I personally don’t have a BSL laser on hand.

Lightburn 1.7 Gweike G2 setup v0.pdf (235.2 KB)

1 Like

thanks for the link.
It worked exactly as described for me, and all settings were imported successfully. However, I’m encountering an issue where as soon as I change anything in the settings or place something on the workspace, it starts lasering non-stop, and pressing stop doesn’t work—the only solution is to power it off. Additionally, in LightBurn, there’s an indicator at the bottom that keeps blinking, even when I’m not doing anything or haven’t started a job. The moment I put anything on the workspace, it begins lasering without prompt.

Dear Jesse,
good day,
This is my experience…
me to find a definitive solution changed the board.
In this link you will find all the steps done

Can you open your Device Settings page (press F3) and take a screen shot of the Ports and Laser Settings page and post it here?

One of the settings on that page is a trigger to start marking from an external input pin. If you have it set to something other than ‘None’ then the software will be looking at the state of that input pin and using it to trigger marking. This is normally used with a foot switch, but if you have nothing connected, that would be a problem.



Hello - im a new user to Lightburn and would like to purchase the product if I can use it to run my BSL based glavo system.

Am I also able to test the 1.7 beta or do I need to purchase a licence first?

If you have the trail version, it should work all devices. When you purchase, you will have to also purchase the galvo option.


Ive just setup the trial version and installed 1.7 over the top.

Detected my BSL machine / imported config and seems to be working perfectly so far.

Will test over the weekend properly.

Only strange thing is my UV is set as a CO2 in the config but was the same as the config settings in seacad.

There is actually no difference… when your installation accesses the network when installed it knows it’s a trial verison and all the different machine types are enabled.

Glad you got it up and running… - have fun


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.