Bug in V1.0.06 - Laser Inline Mode

I noticed a bug in lightburn, when going into the device settings and making the changes (laser control inline), when saving the gcode everything goes fine, but when I close and open LightBurn again, and save the same gcode, without going into the device settings window, the Gcode is saved as M106/M107, instead of using the inline settings I had made.

Therefore it is necessary, whenever you close and open Lightburn, enter the device settings window, and check the laser control Inline option.

This is the same observation from another topic:

Do you happen to know which version of LightBurn when this started?

Adding @LightBurn here for visibility.

This started since V1.0.01 , so in V1.0.00 this doesn’t occurs.
@berainlb @LightBurn

1 Like

Are you connected to a laser when you save GCode?

No, I just save without connect with the laser.

Ok, then I believe that is the problem, and I think I’ve fixed it.


Ok, waiting the new release.

Had any progress?

Yes, as I said - I think I fixed it. I can’t rush a release out the door before it’s ready, so you’ll have to be patient.

1 Like

We are fast, but not that fast. :wink: Fixed, but not out just yet.

We have not produced a new public release with this fix. You can follow our release announcements here: News - Development updates and bug fixes – LightBurn Software

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.