Bug with Z Axis moves

I have been testing the Z Axis moves with my Aeon laser and have found a bug. This has also been confirmed by a friend who has a Thunder laser and sees the same problem so it’s not specific to my laser or my brand. I’d have to find out which Ruida controller each uses. My test file is attached.

I’m getting the “no enough extend space” error when it goes to move the bed for a fill. This only happens with fills and it seems to only happen with a file that contains more than one fill in it and where those fills are colocated (one after the other). This file contains 2 scores (each a different Z axis) and 2 fills (each a different Z axis) and a cut. Depending on the order they are in depends on whether the job runs to completion or it fails at one of the fills. I’ve tested this for the past 3 days with various scenarios and if I send the fills over on their own (selected area) it works. So I can break the file up into pieces and it will work. But more than one fill with a Z axis change colocated fails. My guess is it’s trying to calculate the next move and has some math error. Or there’s some setting that needs to be changed.

S1 = score (line); Z axis 0
S2 = score (line), Z axis -1
E1 = engrave (fill); Z axis -3
E2 = engrave (fill); Z axis -1
C = cut (line); Z axis 0

S1, S2, E1, E2, C = fails at end of S2
S2, E1, S2, E2, C = fails at end of S1
E1, S2, E2, S1, C = works
E2, E2, S2, S1, C = fails at the beginning
E2, E1, S2, S1, C = fails at the beginning
E2 or E1 alone works

I’m hoping this information will help find what the problem is and a solution can be found. I’m coming to this from a Glowforge, where the focus is adjusted within the print head (the lens floats inside it using magnets). So it has a fixed bed. I use the focus height adjustment quite a bit in the things I create so finding that I could get LB to change the Z Axis in a file was a godsend. But I need to get it work with multiple fills after each other in a file.

Thanks - Cathe

LB_ZAxis_test.lbrn (24.6 KB)

I tested the file you provided and I got the same result upon completing the first layer in the job.

Adding to the mystery, when I reset the controller a very unusual result:

Never have I seen this message (“if restart at power off”) as a result of an extend space error.

very weird…

I’ve flagged this and will try to look at this tomorrow (Friday).

Thanks Oz!

oh wow am i glad i found this thread. I was running in to this exact issue, did some search and I’m running in to this problem. I do de-focus engraving a fair bit. Was working on a file with 4 layers, each with more Z travel. When about 90% done with the first layer, NOT ENOUGH EXTEND SPACE.

I’ve created a second file which gives me the same error. I have to engrave each layer one by one right now

2021 01 28 Extend Space Issue.lbrn (10.8 KB)

Oh for what it’s worth, this is on a 2020 Thunder Nova 35. Last time I did something with only 2 layers (1 was z axis movement), it didn’t have this issue.

Have you had any time to look at this yet? Just checking in…

1 Like

I finally had some time to sit down and work through this. Basically, Ruida doesn’t like Z moves being issued in certain places, and the most restricted is in Scan layers (fills). It looks like anything other than an X/Y move in a fill throws that error, so I’ve altered the code emitter in LightBurn to “fake” a layer change, do the Z move, then switch back to the type of layer we were in before.

I’m still working through a few different cases to make sure it’s behaving, but it seems to be working as expected now in all the tests I’ve thrown at it.

1 Like

Thanks. I’d been throwing in a nonsense line layer as well to work around it.

Will this be part of the new release? Watched the YouTube video and it looks great.


Yes, it’s in test now. If you’re feeling brave, I can send you a link to the test version so you can verify that it behaves.

I’m brave. I did volunteer on the post for testers!


1 Like