Camera alignment retention is poor?

My overhead door on my chinese red and black is very stable with good struts.
However, the camera alignment is not consistent and I don’t know why.
I aligned the camera this past weekend. I cut out some earrings and the alignment on the material was spot on.
Fast forward to today, Laser has sat idle since then. I tried to do some small burns on a different item… slightly thicker so I adjusted Z just slightly. The alignment of the burn was shifted in Y a few mm. Frustrating, because I ruined some walnut 1911 grips that now I have to replace.
Cheers,
/T

If the alignment is only shifted in Y, the struts aren’t raising the lid to the same position, or, if the camera mount has a hinge, it could be moving as well. There is nothing in the camera code that changes the numbers unless you’re running the calibration, so the only possible way for things to change is physical movement of something - the camera, or the bed of the laser.

If you lowered the bed so the top of the material was lower than it was when you calibrated the camera, the center point of the camera view would still be correct, but everything else in the capture would be slightly smaller than the design. If you raised the top of the material, the opposite would be true and the capture would be slightly larger than the design.

Mr Oz,
I understand that movement of the camera is not good. OR movement of whatever the camera is mounted on.
When I worked last weekend, I opened and closed the lid several times to check the work, when a piece was finished. The alignment stayed very good between jobs. When I try to push/pull on the lid, it seems very sturdy, and there isn’t any “wiggle” to it.
I had previously moved the lightburn camera (140deg) and mount closer to the bed as you advised in another thread. I bought the N8 filters and have applied one to filter the light to the camera as someone else advised in that other thread. Those changes have improved the camera’s operation somewhat. After all that, of course I recalibrated and realigned the camera and tightened the screws on the mount so it wouldn’t move.
After all the tuning, the capture for the overlay is still blurry and the trace function is almost unusable on anything with any level of detail.
I wonder if there is something wrong with the lightburn camera I purchased?
Do I need a higher resolution camera?

Cheers,
/T

I did some further testing on my issue with alignment…
1st calibrating the lens and doing an alignment. 2nd ensuring that the lid was firm and not prone to any movement. I did calibration and alignment without the ND8light filter.

more testing shows that the Y offset happens with and without the ND8 filter on the lens…
Even after calibration of lens and alignment, NOT moving the camera or lid at all, I am seeing Y offset. I have to use the adjustments to line the overlay up with the design.
I am not an optics or camera person. I basically took a thin piece of packing foam, and cut a hole not quite the size of the camera lens, then taped the filter onto it over the hole. Applying the filter was as simple as sliding the foam over the lens.

I just need to be sure to do a alignment check on a scrap after putting the filter on the lens.

If I could add photos to the post, I would.

Cheers,
/T

This isn’t unexpected, as it’s not really designed for this. If you take a picture of some handwriting with a webcam from 3 feet away, the details aren’t going to be great - you’d have to get up close.

You should be able to now.

I have experienced some similar shifting. I have a rock solid camera mount and tried to set the lid in exactly the same spot. I just want to make a quick suggestion. Check your X and Y repeat-ability after they are referenced. If the shift is only happening at the start of a day or after power has been cycled the prox switches or mechanical are not repeating accurately. This is the start of a stable and accurate system. If you don’t have a good foundation all else does not matter. The absolute coordinates the camera uses will be effected by the machine zero position. The amount off wont necessarily be noticed. I will setup an indicator when I check. If I see issues I will retrofit better switches.

Jim.

I just posted about my alignment problem in another thread. One of the issues I report is exactly this “jump” on Y and my lid is positively stopped and not moving in the upright position. It is repeatable when raised BUT more importantly, I click the Update Overlay button several times and the image jumps up and down. I am not touching the laser or camera when I do this so it is NOT an issue with the bed position, camera moving or lid moving. I can reproduce it.

I’ve had this happen from using foam tape to mount the camera - there’s enough flex for the camera to shift slightly under its own weight. From 500mm away, the camera only has to rotate by 0.114 degrees to shift the view by 1mm, and it’s visually imperceptible, but it’s there.

There’s nothing in the math or code that changes subtly over time - it’s just not possible for this to happen unless it’s physical.

I am using 3M VHR tape. However, if I simply click Update Overlay I see the image move. “Maybe” the tape is preloaded when I open the lid and it slowly relaxes but given the thinness of the tape that seems off too. I’m seeing 5mm - 10 mm shifts.

Is your lid on gas struts and hinges? How much flex is there in the lid?

I have a camera I use for testing that sits on my monitor, pointed into the room behind me. If I trace something in the room, and constantly update the overlay, it’s perfectly still - in fact, it’s hard to tell the camera image is updating at all unless I move my hand around - The math is deterministic, using transforms that do not change other than when in the corresponding calibration window (Lens or Alignment).

The fact that you are only seeing shift in the Y axis suggests that it’s the lid itself, either due to play in the hinges or the struts, or play in the mounting of the camera.

Yes it is and I made a solid stop to stop it in the same place when it opens. In my last post I was trying to point out that I can open and close the lid repeatably. The camera is now mounted so it has no play. The shift issue rarely occurs when I first open the lid and do an Update Overlay. I can’t recall it ever being shifted on first Update Overlay. Its when I click Update Overlay several times that the issue may arise - this without touching the laser, lid or camera. I originally noticed this when I was trying to diagnose why the overlay image is much smaller than my bed and clipping my laser movement and is offset in Y - that’s the real issue I’m trying to sort out. The Y shift is consistent enough that I’m not worried about this other odd behavior at this time as simply clicking Update Overlay again fixes the issue.

What is happening and how can I get an overlay that includes the entire usable bed area? And why won’t it cut a shape that is partially off the overlay bounds but well within my actual laser bounds as I mentioned a couple of posts above.

It is not homed, I simply jogged it out of the way for the photo as I recall. In the image of my second calibration run above and shown here:

You can see the head in the home position in the camera view panel. It is closer to the top and left edge. But most importantly note that the targets are clipped in the Camera Overlay when in fact I was able to cut them exactly in those spots (the cardstock is held down and the bed was stationary after running the calibration target). And if I draw a circle around 3 - even though the overlay shows the target and circle is clipped, the laser frame function frames the target without clipping. It is very confusing for sure. You can see this in the video I linked above in dropbox.

I don’t know how the above got cross posted here from my thread where I was trying to answer your question.

I’m no expert here, but I watched your video. I noticed your number 3 calibration target is missing the circle around it. Just a thought, but try changing the scale parameter when you do the alignment so the targets aren’t so close to the edge of the bed. Almost seems like part of the calibration target isn’t being burned because it’s going out of bounds. At least changing the scale will let you know if that’s the case.

That target should look like this…

See how yours is missing the circle around the target?

In reality, there is about 25mm of usable area above and below those targets - my bed is 450mm high. I’ll drop the target scale to 275% to add some extra safety but this was my second run, the first time was 150% and basically the same thing happened.

Just a thought to try. I too went through some frustration with the camera but mostly it was my lack of understanding of how it worked. Not saying that’s your case, but it was mine. I also found that trying to adjust focus during the calibration was a pain because the image was so small. I used the update overlay several times and adjusted focus that way then went and did the alignment. I did notice that adjusting focus significantly made everything move. Think you have to have focus set and leave it alone after doing the alignment. Again, maybe not your issue, but something to note.

And if I understood your other posts you were saying that after alignment you could open the lid, not touch anything on the machine, click update overlay, then click it again, and the image would appear to jump or shift?

I haven’t touched focus since I set up the camera. So that isn’t it.

Notice my comment at the end of the video - running Frame correctly frames the 3rd target without clipping so the circle I’m trying to cut should actually be cut. But it isn’t. And on my laser (Ruida controller) if the image/vector is outside the work area, it simply clips it doesn’t not print the entire image. So in this case if the bounds were an issue it would cut a semi circle around the target but instead, it doesn’t even move to the target!

Yes, exactly. And if I click update overlay again, it jumps back to the original (presumably correct) position. This is intermittent behavior but does occur frequently enough to be a nuisance. And the shift is always along the Y axis.

I thought I was seeing the same thing originally. So much convinced of it that i took the camera out and mounted it in a vise and pointed it at a busy wall. I found that it absolutely never jumped when solidly mounted that way. Might be a pain to remove it and do that but it will unequivocally answer the question of whether the problem is truly the camera moving via the lid, mount, etc.