Camera blurry when capture taken

I have been setting up my laser to use with the camera. I changed from the cheap pin hinges to proper hinges to prevent movement. I was running a calibration and noticed when i do a capture the image becomes fuzzy or out of focus. Anyone else notice this? In the camera window the image is crisp, auto focus works great just don’t know why the capture becomes blurry.

What kind of camera, and on which OS?

If the image in the camera window is small, but the capture is full size, that might explain it - Many cameras will capture at low resolution on Windows by default, and the framework we use to interact with them doesn’t allow changing the capture resolution on Windows. When you do the lens calibration, you should see the resolution displayed with each capture.

I am running windows 10 64 bit, I have a 5MP Full HD 60 Degree View Angle Autofocus Mini USB Camera. The Image is extremely clear in live view and auto focus works great I just dont know why the low resolution/ blurry image. The image i the camera is large, the capture is zoomed in a bit more.

When you capture in the Lens Calibration window, it will tell you the resolution of the captured image. If the camera you have defaults to low resolution captures, you’re unfortunately stuck with that for the time being. The framework LightBurn is built on is how we access cameras, and that framework, on Windows only, does not allow changing the capture resolution. It’s a dumb limitation that we plan to find a solution for, but it’s going to be a lot of work to fix.

This is the entire reason we sell our own cameras - we got the manufacturer to force the firmware to default to the highest capture resolution, not the lowest, to get around this limitation, and there are a number of other options available that I can point you at. One of our users found a utility for changing camera settings and he was able to run that at the same time as LightBurn and said it changed the capture in the software. I’ll see if I can locate that for you.


Ok, i did some testing. Lightburn is capturing images at 640x480 only. I tested on windows 10 app and the images are taken at 2540x1944. So it seems lightburn is setting that somehow.

No, you have it backwards - LightBurn is using the default resolution for the camera, and Windows camera app is changing it to the higher resolution.

OK, i would appreciate it if you can direct me to any temporary fix. I have a 8 and 12 mp camera I also want to try but unless i get this squared away it wont work. Thanks

I haven’t been able to figure out a way around this myself. There are some cameras that just work, because they default to higher resolutions, but most default low. It’s frustrating for me as well.

I have one here that’s not one of ours that defaults to high res: model UC50MPB_L36 that I purchased from Amazon.

And there are a few others I know of. Try the other ones you have and see what happens. I have been looking into fixing this in the software, but it’s a huge undertaking.

Have you gotten any of the 8mp cameras? I need a 60- 70 degree camera. Mine just keep defaulting to the low resolution

What are the dimensions of your laser bed?

I have a few of them, and have done some initial measurements and testing. I have a couple of very nice quality ones with either a wide 110 degree lens or a narrower 90 degree lens. They use very large sensors, and have a 16:9 aspect ratio.

The others are cheaper, and the lenses are similar to the existing cameras, but the sensor is 8mp instead of 5mp, and have a 4:3 aspect ratio.

my work space is 18" x 12" (457 x 305 mm).

8mp would be overkill on that machine - we have 5mp 60 degree cameras in stock that would work for you. The capture size is 2592 x 1944, so you’d get roughly 6 pixels per mm of bed area in both directions, and that’s more than enough.

ok, i just want the best resolution possible.

Have you tested any with auto Focus?

I have one device that’s supposed to, but haven’t seen it make much difference yet. It should’t matter, and in fact, could work against you if you had a tall or narrow workpiece - with manual focus, once it’s correct it will stay that way.

ahh I see. let me play around with the driver for my current camera a bit more. If I cant get it to use the high resolution I will just order yours.

Was playing around with the driver’s and registry. There are 2 issues, one windows 10 does not allow to set a resolution as default and uses the generic driver’s default or the embedded camera’s lowest resolution. Do you have driver’s for your camera’s? I am working on changing the embedded firmware settings and see if that works.

Our cameras use a standard Windows UVC driver. The manufacturer changes the default resolution of the camera in the firmware when they’re made.

I just got the camera. I went through the calibration but there is about 2 inches on each side that your camera does not see. Not sure what is wrong. My other 60 degree camera covers all my bead easy and then some. any ideas? hate to have wasted money.

Have you focused the camera? That shouldn’t affect the view on either side, but it will certainly affect the resulting image.

When you ordered, did you work out the math for the mounting height, or did you just get the 60 degree because you already had a different 60 degree camera that worked? How far from the bed is the camera mounted?