Can not get Lightburn to communicate with D1 laser

Hello, I have a Xtool D1 10 watt laser and Laserbox basic woks fine. Lightburn does not work at all. I only have used USB. It says it is “READY” but does nothing because it says it is busy.
It does not send anything to the laser that works. It just sits like it is not connected. My laptop is an HP Probook 4520s with windows 10. I did the updates in Laserbox of the software and firmware too. I did the dowload and import of the driver per the directions in the setup for lightburn and D1. At this point I’m going buggy trying to find something that will work to get this going. Thank you in advance for any help in solving this. #hardware #lightburn-software

Can you confirm the version of the applied firmware? Some people are not getting firmware updates through Laserbox for some reason.

Current version
V40.30.003.01 B9

New Firmware version
V40.30.003.01 B9
emphasized text

That version should at least connect. Can you take screenshots of Edit->Device Settings and a full screenshot of LightBurn?

I hope this is what you need? if not just tell me what to do different

That screenshot is Edit->Settings. Can you get a screenshot of Edit->Device Settings please?

Also, a full screenshot of LightBurn without any other window open and Laser window on display.

I think I saw some people have luck connecting to D1 by enabling “Enable DTR Signal” in Device Settings. Can you try that?

Also, you’re currently in Beginner Mode which you may want to turn off in Edit->Settings. You’ll see references to things on this forum or in documentation that won’t be visible to you while in Beginner mode.

i’ll go check these real quick.

It still will not frame or really show any movement to the laser

After doing both of those

Beginner mode won’t affect the connectivity. DTR signal might have.

Can you restart LightBurn and then capture the output of the Console window and paste here?

okay, be right back with the screen shot. I thank you for this help.

I moved the USB cable to another port and tried to frame and cut but it only gave this error

Are you certain that the laser is on COM3? Is it possible that it’s on a different port?

Also, have you tried doing a full power cycle of your laser? Shutting off, unplugging, and then turning back on?