Can’t get LB to find my laser on Mac

Light burn can’t find my laser. I’ve added manually and it still won’t connect. I also tried on my daughters PC and still had no luck. Idk what to do.

Not much info to go on.

How? Which MacOS? What have you tried? Can you see it in ‘about this mac’?

Are you connected with a USB cable, or with Ethernet? If Ethernet, have you set the IP address for the laser? Initially, I had difficulty with connecting through the Ethernet cable,but there are some good tutorials and also some great members to help out. We neeed information on what connection, and what controller you are using, what operating system, etc.
I have faith that you will resolve this.
Charlie

I was using usb. Could not connect. I even added the machine manually. Going to buy an Ethernet cable today and try that. From what I understand I will need to assign an IP address to the controller physically before I can actually connect?

If you search this forum you will find a lot of references to USB drivers on the Mac causing trouble. Lightburn has a sequence of steps to try to get the problem fixed. Did you try to add the laser manually? Read this: Mac, Ruida Controller, doesn't recognize USB

At the bottom o the thread: macos - How to release/reset serial port FTDI devices - Mac OSX - Super User