Cannot Connect to Ortur LaserMaster 3 over USB on MacBook Pro -- Only LaserExplorer for Android over WiFi -- Firmware Update Link is Dead

I just bought an Ortur LaserMaster 3 on Amazon and I’m trying to make it work before the return window closes.

I have been trying to connect my machine to LightBurn, which appears to require a USB connection. The only way I’ve been able to use the laser so far is through Laser Explorer on Android (which is garbage), so I know I can talk to it over 2.4 GHz, and so far the only way I can see to get LightBurn to work over WiFi is if I set up USB first. I’ve tried three different USB A-to-C cables, bought a brand new cable – nothing works.

The firmware update site at https://ortur.tech/latest-firmware/ is a dead link now, so I don’t know how I’m supposed to update the firmware for this thing.

I’ve been trying to make this thing work for the past week and I can’t help but think I’d be much further along right now if I’d just spent the extra $500 to buy a Glowforge instead. At least I could have been making things this past week instead of fighting this thing.

Knwon issue if you have a M1 machine
Get yourself the cheapest, dumbes USBC to USB-a hub. i mean… really cheap and it should fix it.

This will force usb connection to be done by 2.0 standards which MacOs is way less fiddly about.

Tried a couple old USB-A hubs – no luck yet.

The only USB-C hub I have would require a male-to-male USB-A cable, and all I have are male-to-female extenders.

So you do have a M1 correct?

Try this.
Power on machine, plug original cable with adapter
Open a terminal and type
ioreg -p IOUSB

Press enter
and post output please

No, it’s not an M1 chip. it’s a 2017 machine with a “3.1 GHz Quad-Core Intel Core i7” chip.

±o Root <class IORegistryEntry, id 0x100000100, retain 16>
±o AppleUSBXHCI Root Hub Simulation@14000000 <class AppleUSBRootHubDevice, $
±o Apple T1 Controller@14200000 <class AppleUSBDevice, id 0x10003a801, re$

Let me think

Assume you do not have another computer to test?
windows maybe

if not, please check your USB port on the OLM3 that its healty

Can you connect to machine via WIFI?

I can connect to it with Laser Explorer (on Android) with WiFi, yes.

EDIT / UPDATE: … we found a Very Special Male-A-to-Male-A USB cable in the Ortur box. >_>

Using that instead of the A-to-C cables, we were able to at least hook it up to LightBurn on my friend’s Linux box. Trying to use an A-to-C hub to make it work with my MacBook caused it to short out / turn off as soon as it was plugged into that hub, and at least now we have -A- working USB connection with -A- machine running LightBurn, even if it wasn’t the one I wanted.

It’s at least enough progress to try using it to make things tomorrow.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.