Cannot delete lb files

for some reason i cannot delete lb files, LB is not open,none of the files are open, any help

You offer so little when you post. Why? You could let us know more about what it is you see. We are not there to observe what you do. Today, I see you are asking questions, but provide very little, forcing us to ask for information you should be providing with your post.

We have asked you to update your forum profile to include you machine listing, and you have not done that. We are here to help. Why do you make the process harder than it needs to be?

Are you saying that using your OS file manager, you cannot select a file with the ‘.lbrn’ extension and delete that file? What Operating System? What are the exact steps you have tried?

i am using rudia, i cannot delete a LB file, also i cannnot get my laser to work, i was doing as you said the last time,to right click on Devices and it worked for a while but now it will not work at all, i do not have another LB open like some people have said,the USB is fine.

  • Do you get an error of some kind?
  • Do they appear to delete then just come back?
  • Is there any other information you get from the computer that might be relevant?
  • Are the files stored anywhere that’s managed by a cloud service, like OneDrive, iCloud, etc?

When you post “I can’t do this”, for all I know it means that you’ve broken your fingers and are unable to press the correct buttons. Obviously that hasn’t happened, but you haven’t given any indication other than “I can’t” as to what might be going on here - that’s what Rick is on about when he says “you offer so little” - we don’t read minds.

HOW HARD IS IT TO UNDERSTAND dont you think if it was any of the above i would say see attachment this is all that HAPPENS when i try to deletenot delete , I CANNOT DELETE LB FILES OK IS THAT NOT PLAIN ENOUGH,WHAT MORE DO YOU WANT ME TO SAY, WHEN I RIGHT CLICK TO DELETE A LB FILE IT WILL NOT DELETE,this pops up"“see Attachment”" .and the there is the second problem, i was onto you a while back about the ““Devices”” you told me to ,right click, on the Devices tab and that would work and it did work, for a while, now when i right click on the Devices tab,nothing happens, i am dead in the water,no matter what i do, this is what i get, see second attachment.dis

That’s the information I was looking for, yes. You didn’t mention that pop-up before, you just said “I can’t delete files”. COM Surrogate is the Windows process that runs the thumbnail preview tool, so that’s what is holding on to the files for some reason. I’ve seen a couple others with this issue, but I’ve never had the problem myself, and haven’t been able to figure out what causes it. Everything I’ve found online so far suggests this is an issue with Windows itself - I’m still reading to see if I can track down why it’s happening.

Try changing the View in the windows file explorer to “Details” instead of thumbnails, and see if that helps. If it doesn’t, restarting your PC should clear those locks.

You can also do this:

  1. Press Ctrl + Shift + Esc to start Task Manager
  2. When Task Manager starts, find the COM Surrogate process and right-click it. Choose End task from the menu.

For the laser not connecting, do this for me:

  • Power your laser and connect it to the PC
  • Run LightBurn
  • Go to Help > Enable Debug Logging
  • Right-click the ‘Devices’ button
  • Count to 5
  • Click the ‘Stop’ button
  • Count to 5
  • Quit LightBurn

You’ll find a file called LightBurnLog.txt in your Documents folder. Attach that here so I can have a look.

It is easier to catch flies with honey than vinegar. yep, I am butting in. I get being frustrated but those guys are trying to help. butting out now.

1 Like

Hi Ok so i did the COM Surrogate process and right-click and that seems to have fixed the problems, there wasLightBurnLog.txt (108.4 KB) 8 LBs running in there, thank you for your help. please see attachment

You said, “8 LB’s running in there” - do you mean in the task manager? That’s why you can’t talk to your laser. Not sure why those are hung up like that, but kill them.

Only one instance of LightBurn will communicate with the laser (the first one you launched), so if that is hung up somehow, it’s preventing other copies of LightBurn from talking to your machine.

hi yes I mean 8 running in the task manager I can also delete my files as well, you learn something new every day.
happy New year


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.