Cannot get laser to keep going

I’m wondering if anyone has encountered this problem. I cannot seem to get some of my jobs to complete themselves without having to babysit them. It is an intermittent problem, I do one project and it’s fine, the next will get one letter or image and I will have to come back, delete that item and hit start again most times 5 or 6 times in a job.

This is not normal. What’s happening in between these steps that’s making you go back? Is there an error message? What do you see in Console? What do you have to do to recover?

It’s like it doesn’t know that it has anything wrong, it’s still counting down the minutes as if it is moving, but there is no movement at all on the laser. I have to hit stop and restart the project over minus what it has already burned. It kind of reminds me of when I go to do a Frame sometimes, it gets into position at the start of the frame then just doesn’t move at all, once the frame is complete, it goes back to origin or wherever. It’s like it thinks it’s doing the movements but it isn’t. Usually if I let the frame run its course, it seems to unscrew it self from that moment. But my projects take way too long to let that play out. The square frame seems to work most times, but the circular one is like almost never working. I feel like this is because I’m using a mac.

I was on an Intel Mac for a while using LightBurn without any such issue. The M1 throws a variable into that but others have been using it without fuss.

This sounds like it could be something where the USB is losing connection silently.

  1. How are you connecting the Mac to the laser? The specific type of adapter you’re using might be impacting that.
  2. Try a different USB cable. The one you’re using might be flaky
  3. Try a different port on the Mac

One other thing, assuming you’re using the Ortur Laser Master 2 Pro in your profile, is that Ortur has recently released a new series of drivers for this line that’s generally recommended to upgrade. Take a look:
Ortur – Firmware Repository – Ortur

Adding @OrturTech here for visibility.

1 Like

Could i ask if in console you can type
press enter
and post output to know which version you running?

Since I’m on Macbook Air it only has two ports, to expand I have this, might be that I need to go direct to the device then which leaves me with only one port for everything else which sucks:


[ORIGIN: China]



[MODEL: Ortur Laser Master 2 Pro]

[OLF: 170]

[DATE:19:08:08 - Jul 12 2021]



Target buffer size found


Definitly would try to update that firmware

Yours is launch firmware and it has a few issues

also what LB version you using please?

1 Like

The key is going to be finding the root cause. It may or may not be the adapter type but going through a hub definitely complicates things.

I think the firmware update is an easy first try although I worry that if you’re having connectivity issues while burning that it could extend to the firmware update. You may want to plug in directly for that just to reduce variables.

If that doesn’t work you can try other things one at a time until a solution is found. Might be that the hub is fine.

1 Like

1.0.06, OK thanks, didn’t even think to do this. Thank you!

Thanks so much for all the help!

I just watched a video that says I cannot do the update on a Mac, is this correct?

Sorry reading the document, it looks like I can on Mac now

So this problem continues to plague me. I have now updated the firmware and removed the hub from the equation and run a line straight from the laser to my Macbook. Any other suggestions from anyone?

What exactly are you experiencing now? Has any behavior changed? Does the laser sometimes connect?

If you’re sometimes connecting make sure that the port is set to the right port in Laser window. Also try right-clicking the Devices button to reconnect.

Basically same as before. It’s an intermittent problem. I ran no problem for an hour long run, went to the next file and it stopped after about 5 mins. I connect no problem, the laser runs for a few minutes then just stops out of nowhere it stops (it always finishes the image it is on I will say), the clock keeps counting down though as if it does not know that it is stopped. Interestingly though, now that I think of it, I think it was the same program and time in the program that it happened last time. Perhaps the file is corrupted. Odd though because I’ve run that program at least 50 times before and never had a problem with it, just all of a sudden.

And it has happened with a bunch of other files since then.

Can you review this post from @OrturTech in another topic?

Try the process of removing the connector to the laser module. Does a known bad design finish properly? At least in terms of motion?

If so, possibly a power supply problem.

OK I will try that thank you!

In regards to this comment, sometimes it will finish, sometimes it won’t, but when it screws up, it just stops motion all together until I reset the laser (i.e.hit stop, the home it) Hitting stop will cause the program to stop (laser itself has already been idle),

Just for clarity, is this after you tried unplugging the laser module before running a job? Or was this in your previous error runs?