Cannot get LB to recognize OMTech 60 on Mac

Please be gentle; retired 13 years, technology stale and complete laser newbie. Downloaded LB, bought key with OMTech. LB comes up quick (cannot find on Finder Application files but program starts, looks for a laser, and nada. From what I gather from searches it’s a driver problem. OMTech came with thumb drive that I THINK should have any missing drivers, and when I open it seems to only have MS PC files (.exe). So it would seem I cannot load any appropriate drivers onto my Mac Air to get the OMTech to talk. Am using correct PC USB port on laser.
Edit:Using a new Anker 5 ft USB cable. See where some say use < or = 3? Have tried turning off Wi-Fi. No luck.

You can try downloading the latest FTDI driver for macOS 11/12 here:

If that doesn’t help, setting up an ethernet connection may be the most reliable option:

Thanks. The USB driver still wouldn’t go but I’m going to try the Ethernet solution…

Ethernet is the only way to go, if you can.

Keep in mind that the Ruida is a static ip device…


I second that.

I.P. Just works, and works well.

But! If you’re anything like me, even though it’s running over network connection, It’ll drive you crazy knowing that the USB connection wouldn’t work.
So! I would suggest you try installing CH340 drivers. This seems to remedy all sorts of connectivity issues between GRBL driven 3018 CNC machines, and certain 3D printers. (even when they don’t use that particular chipset).

With all of the major changes in OSX, there have been many devices that have just fallen by the wayside, and then one day some enterprising young lad pops up and says “Install Candy Crush”, so some people do, and come back to report that that fixed it!
I think sometimes it’s not actually the proposed “Fix” that was the solution, but rather part of the process that does the trick.

When one person says it, I chuckle… when I see 4 or 5 “Thanks! That worked!” posts, No matter how much it doesn’t make sense, I just click my little “like” button, and move along.

Well, no go. I tried the Ethernet solution yesterday, had USB-C to USB-A adapter in my Mac Air, then a USB-A to Ethernet adapter to a cable to the laser. I was suspicious of the adapters, one was pretty old but both were Apple. So to be sure I got a new direct USB-C to Ethernet adapter today from Apple and no different. Used the above method, Air showed xxx.0.0.1 as address so used xxx.0.0.101 on the Ruida controller on the OMTech. Did the manual instructions for size, etc. Fired the controller and computer up, controller shows LAN ON, but LightBurn shows no device found. Based on other reading I had WiFi turned off as it said it could confuse the computer. Any further suggestions appreciated! Thanks!

Not sure what Air is… does that mean you can see it on the local lan?

Did you plug the Ruida into your network?

Sounds like you plugged it into the computer… probably won’t work as the computer expects to get an address and won’t from the Ruida…

It needs to go through a router/bridge for a simple connection.

Can you plug it into your local lan?


Mac Air ….MacBook Air, thin laptop. Only has two USB-C ports, nothing else.
Wondered about the LAN as I really don’t have a network per se set up. Have 3 computers that work via WiFi. But, the provided material said to set an IP address on the Ruida (with first three number sets same as found on computer, last random; match that to LightBurn device characteristics) so I assumed if connected to computer it would recognize. FWIW when I set it up and connected the two the Ruida controller said “LAN on” and if disconnected it said LAN Off. So you’re saying Ethernet method cannot be used to communicate between single computer and a device like the laser?.

Absolutely not… I ran mine that way for a while…

When you plug into a network, there is a negotiation that occurs. The computer asks the router for an ip address… the router assigns one to the computer.

The Ruida doesn’t have server software for ip address, so when you plug it in to your pc, the pc can’t get an address and can’t talk over the network.

The problem is that you have to set that specific port or Ethernet connection to be on the same local network as the Ruida.

If you have wifi, you can find a router/bridge that will wire the Ruida up to your network… and you access it like any other network device.

Do you have a Raspberry PI laying around… you can make it into a Lightburn bridge or buy one from Lightburn.

I ran for quite a while on a $12 wifi bridge from Amazon… The PI from Lightburn has software in it to help, but anything is better than usb.

The Ruida will have lan:on if the hardware is connected… doesn’t mean the software is working.

Make sense?


Makes sense; was confused about “network” when all there was was cable from computer to Ruida. I have what I’d call a WiFi booster for far end of my house that has an Ethernet port on it. Later today will attempt to connect that to Ruida and see if can get communications going. I assume the protocol attached above is still appropriate, as in get the IP address from Mac computer terminal, set Ruida to that with different fourth set of numbers, then set that address in the LightBurn program. Thanks for the help!

Usually you have a local network with a number of devices out there, besides your laser, like a printer.

Since the Ruida is static, the router needs to know it’s address so it doesn’t re-issue that address to another device.

Most routers have a simple way to associate a mac address to an ip.

On my Linksys, on the network map, I can just click (or right click) and it will use that device and it’s IP to bind the address so it won’t be reissued.

The reasoning is to put the laser high +100 ip’s away from your highest network IP, not your computer IP… unless you have a hundred devices, it should never get this high… and be relatively safe from other devices on your network.

It needs to be on the same subnet… so the first three octets would be the same, only the last octet would change…

This will probably work out fine…

Let us know…

Good luck


Got it. What was tripping me (who doesn’t usually wander into ethernet beyond plugging cords in) up was the instructions included above of “How do I connect a Ruida Controller with Ethernet.” It instructs to pick an address from the computer using the first three IP number sets from the “terminal” of the Mac. I finally thought that it should come from the router. Intuitively, since the wifi router showed all clients with same first three IP number sets, using that and picking a new final set for the Ruida, entering it in LB, and bingo. Thanks for the help! Now I can play with Lightburn!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.