Can't connect to Mr Carve M3

I have a new Mr Carve M3. I have verified the hardware functions, but neither LaserGRBL, nor Lightburn are capable of connecting. Please help me find the right settings.

I just recently received a new Mr Carve M3: Most Versatile Laser Engraver For All Materials by Mr Carve — Kickstarter and am trying to drive it with Lightburn. According to the kickstarter it is compatible with Lightburn and LaserGRBL.
I have been able to use the software that comes with the Mr Carve M3, and been successful at burning a couple of test pieces. Unfortunately the software that comes with it is not user friendly, and I would like to drive it LaserGRBL or ideally with Lightburn. Unfortunately when I attempt to connect, the “Laser” tab says ready, the “Console” tab still is “Waiting on connection”
On the console, there is the switch for “Show all” and when I click that, it shows G0 repeatedly. From what I found, that is Lightburn posting checks to know when the laser finally connects.
I have switched baud rates for the device, I know 9600 and 115200 are the defaults, but I tried every one that is an option. None of the baud rates were successful at connecting. I have also even tried the DTR setting with no luck. In troubleshooting, I have attempted to connect to the laser thru a standard terminal program, (tio and screen on Linux, putty on windows) without any success. When I connect via a terminal, I get unprintable characters when normally indicates that I have the wrong baud rate, but I can’t seem to find the correct baud rate. If I bump it up to 921600, I almost get legible feedback, at least then the characters are printable mostly.
I have tried different baud rates, stop bits, parity, flow control. None of them have any effect. I have seen others on YouTube who have connected Lightburn to the Mr Carve M3, but they just gloss over the configuration.
As I said earlier, I believe I have eliminated hardware as the issue, as I can connect to it with the provided software, and successfully have engraved a couple of things. Additionally, I have attempted to connect with Lightburn on Linux, Windows and MacOS. So I believe all I have left is that there is a setting that I have just overlooked.
Please Help

These types of lasers that have proprietary software and phone apps typically run two sets of firmware, one proprietary and one based on GRBL. You’ll need to make sure that the laser is running in GRBL mode. Do you know if there’s a way to detect this or force it?

Also, are you certain that the USB Serial drivers have been installed? How does the laser show up in Device Manager in Windows or under lsusb in Linux?

If the native software is connecting through serial does it give you an indication of settings there?

Thanks for the response. I don’t know of a way to detect which firmware it is running. There doesn’t seem to be an obvious way, and the manual doesn’t describe an option.
As for the USB serial driver, yes this has the CH340 drivers, and I did update them. They were required as part of the native software install. I even ran into the Linux Braille udev issue, and resolved that. Without the drivers loaded, Lightburn wouldn’t even “ready” the laser tab.

And no the native software doesn’t give any indication of settings. It has a big “Connecting” button, which when selected pauses for a couple of seconds and then adds a gear icon with the label “Set”. If I select that button, I get a window with “weak light 4%” and a slider, and then a checkbox with “roller”. Neither seem to connection related. The software does have a “help” button, which takes me to a Chinese site with user manuals, and videos, and software for a bunch of other laser cutters that aren’t mine.

Interesting. I wonder if you could probe the connection from the native software to get an indication of how it connects and what the stream looks like. Perhaps with Wireshark.

In Windows can you run this in a CMD shell?

mode COM#

where # is replaced with your com port. That should tell you the set baud rate although I’m not sure if this can determine the dynamic baud rate as it changes.

I ran mode com3 before connecting with the native software and com3 reported 19200 for the baud rate, and then I ran the native software, and of course while it was connected mode com3 errored. But after I close the native software down, I ran mode com3 again and it told me the baud rate was 921600, which was one of the better results when I was testing earlier. I tried the terminal with all the flags from mode com3 but I get garbage characters still. So, maybe the right baud rate now, but some other check box is off… I tried the DTR on this as well, no improvement.
I may have to see how well wireshark works on my surface tablet.

I’m going to guess that it’s actually connecting but that it’s not passing ascii text. Possibly a binary format or some sort of transmission protocol (e.g. xmodem). If true, that means it’s not running in GRBL mode I’m guessing.

Yeah, perhaps there is something to switch it. I can’t find anything. Nothing on the phone app or the native software seems to indicate an option to switch. Almost to the point of using a large hammer to find the right setting.

Have you seen any verified reports of people running LightBurn on these machines? I checked a few videos and none of them actually were running LightBurn.

If you watch Naomi Wu’s review of the M3 you can see she uses Lightburn. Using the Mr. Carve M3 Laser to Make Buterin-Wu UV Lamps! - YouTube
For a very brief moment you can see she is using Lightburn, it looks like she is using the GRBL device profile, and the console has “layer: 2mm laserply…” Which seems to indicate that the console is also working properly. I’m not so experienced with Lightburn that I would be able to tell too much more from analyzing the single frame… Does “Stream completed in 4:11” actually indicate a different option that I am totally not using?

Ok it looks like I am not totally off my rocker. I just saw this
“Also manufacturer said to just wait for how to setup with lightburn, they will make a video and provide a firmware update.”
apparently they haven’t released the firmware, or instructions on how to get this on Lightburn. You were absolutely correct. Now it looks like I get to wait on those instructions.
Thank you for letting me know I am not crazy.

Funny because I watched her video and must have completely zoned out during that part. The “Stream completed” message is inconsequential. It’s just indicating how long the last job took.

But if you were connecting you’d see similar Console messages.

That field is showing the device name. “GRBL” just happens to be the default device name for GRBL device types.

Have you reached out to the manufacturer for any support or instructions on this? The situation is rather peculiar.

I have the same problem…
switched from LaserPro to Mr Carve M3 (kickstarter)…
so wait for a firmware update (didn’t find the info…)?


Not sure but it was uncertain how to get the connection to work as it seems to be undocumented. I’d suggest reaching out to the manufacturer.

I also received my Mr-Carve M3, and have used Lightburn exclusively with my last smaller laser with no issue. This unit will not talk over serial to LB no matter what I try. FWIW I’m using a MAC.

I wrote a comment…
I don’t think there will be an andword…

@ Damashii & Racerx43
can you refer to my comment
maybe there will be a quick answer…


I replied to your note in KS - great idea - thanks !

Someone named Lei Hu on the Facebook “Mr Carve M1 and M3” group posted this link
I have downloaded it, it looks like it contains videos and instructions on how to upgrade it. It does look like you lose the ability to use the bluetooth app after you upgrade.

1 Like

I have loaded the firmware on my M3, and can confirm that I am now able to connect to it with the 115200 baud rate on Lightburn. I know I am an unknown poster on the internet, who just offered up a file that I in turn received from some random on facebook, so this firmware def look suspicious. Continue at your own risk. Your mileage may vary, be kind rewind, and all that junk.
One thing I have noticed, homing on the new firmware doesn’t work straight out of the box. The x axis is currently homing to the wrong location when I hit home on Lightburn. This hopefully should be an easy fix, I just wanted to post this so others can get online, while I get my laser squared away.

Easiest fix is to go to Edit->Machine settings and toggle the X homing direction.

If you want to explore this more then run this in Console and return results:

1 Like

got mine online and cutting with the patch that Damashii tried - I did it in a sandbox windows machine running lightburn, and had a network analyzer running so I could see if it was behaving. :slight_smile: So far so good. Pretty impressed with the Blue diode cutting some shapes, been able to step down power output steadily… more experimenting to do.