Can't get LightBurn to stop cutting the same area twice


(Michael Czeiszperger) #1

This has been driving me nuts: the design has only single lines, but the laser cuts most of the sections twice. I’ve tried all the options I can think of and its still double cutting. Turning off Optimize Cut Path seems to help, but many of the sections are still cut twice.

I design was imported form a DXF generated by Fusion360 if that makes a difference.

I’d be happy to supply the file.


(Chris Leitch ) #2

Sometimes when importing dxf files the lines get doubled up.
This can happen if the shapes had both a fill and a stroke.
You might be able to use “Edit => Delete Duplicates” if they are true copies of each other.


(Michael Czeiszperger) #3

Thank you for the suggestion. The reason I’m posting about a possible bug is the laser is double cutting but there are only single shapes:

27%20AM

I’ve been playing with every possible option I can find to solve this as its holding up production, to no avail, which is why I resorted to posting here.

Strangely, turning on Optimize Cut Path (with any options) makes it worse.


(Michael Czeiszperger) #4

Interestingly, if I delete a shape it disappears, i.e. there is no duplicate shape behind it.

BUT, if I use the Edit Node tool and move a node, then it appears as if there are still two shapes there.


(Oz) #5

Can you email the DXF itself? It looks like it was auto-joined into two loops and I’m looking for good test cases to prevent that.

This happens often if you export the silhouette of a shape - you get an outline for both the top and bottom silhouette of the shape, doubling all the lines.


(Michael Czeiszperger) #6

Sure, where can I email it?


(Oz) #7

Developer at LightBurnSoftware dot com