Can't get the laser to home correctly

Hi, I have a 1300x900 chinese 80w laser. I changed the original leetro controller to a Ruida 6442s. No matter what I do the laser will not home to the back right where the limit switches are. Whenever I turn the laser on, it seems to try to find a new home and crashes into the sides. Any help would be appreciated, thanks

Here are instructions on configuring a Ruida controller, and setting it to home in the correct direction- some trial and error will be necessary, but there are only so many possibilities. :slight_smile:

A good start is to see which way the head moves on power up. on the machine console will stop the homing procedure.

If one or both go away from the home switches invert the ‘homing direction’ in the controller for these axes.

Pressing ‘reset’ or a power cycle and it should home. There are some other things you will need to deal with. I hope you have a copy of the original configuration…

Ruida have not only ‘homing’ switches, but can also have ‘limit’ switches, which are not used very often. They are not interchangeable.

Once the Ruida boots/homes, these homing switches are ignored.

Good luck, I’m waiting to hear how easy this goes…


Tyler, thanks for the reply. I found that right after I posted.

Thanks for the reply. No, there was no Original Config, so basically a from scratch setup. I managed to get it to Home “almost”, which is the top right where the limit switches are. When it resets it goes home but, slowly moves to the left to where it thinks home is. If I do a reset or power cycle it homes to that position and again slowly moves to the left. The travel is about 3.75 inches and it resets every time you power cycle so the “home” location “moves” on down the “X” axis everytime it is power cycled or reset. The “Y” axis seems to be fine. What are your thoughts ?

I’ll have to think about this… Most of the information that is vendor supplied will be missing. If you can get into the origianl controller and get the information, via the console if need be it might be worth having.

I get the impression that when it resets, the X axes ‘walks’ across the table. It isn’t going back to the same place after a reset.?


Yes the X axis walks when it is resetting. Then if the machine is powered down or reset it goes to where it walked to the first time then walks again another 3.75" basically setting a new “Home” position each time.

Also after it stops “walking” it does set itself to X0, Y0

Ok, I got it. Thanks for your help. It homes and no walking but, the X axis is off the actual table about 1/4" so I might have to move the limit switch in to correct that.

I would suggest you examine it closely and see if it ‘homes’ then moves off. It may have something set. It should back off a set amount then return… is it doing that?

It would have to bring my machine up and look at the configuration of mine. I thought there was offset that can be applies and some other homing and positioning settings… Can’t do it now, but will try by tomorrow…

Go into ‘Edit → Machine settings’ and save this configuration now, you can reload it if you bungle something…

It may not be right, but it will save you from having to reset it … save them as you make progress…


Yes, I checked it and it does go “Home” and then it backs off a little bit. although I still think I need to move the “X” limit switch as it is slightly off the bed. Thanks very much, I appreciate your help. Now onto getting everything else done.

Hi Dave, I have a Chinese Red/Black laser with Ruida 6442 controller and have set my machine to offset the laser from the home position a little in order to provide slightly greater clearance from the side of the machine and align the laser with the honeycomb bed. When my machine is turned on it homes to the top right where the limit sensors are located, then once homed on those sensors, the controller moves the laser a few millimetres away. The settings for this are located in Lightburn under Edit->Machine Settings then scroll down to Vendor Settings. At that point I expect you will get a message that you will have to okay before it will expand the list. Scroll down to X Axis settings->Home offset (mm) or Y Axis settings->Home offset (mm) as applicable. You can use these settings to offset your lasers home position from the physical home position determined by your physical sensors, ie. as far as operating the laser goes, the Offset position becomes 0,0 position and is not overwritten by the normal user interface, eg. pressing Home or Origin buttons.

I’m happy to share my default settings if it helps in any way. My laser is a 700x500 so some tweaking of the config is certainly going to be needed but I expect there are those like Jack with far more experience with this sort of issue than me.

Oh, while I think of it, I had a weird issue where my machine would misbehave on power up while homing if I had my laptop connected via USB but not turned on and running Lightburn yet. The fix was to either disconnect the USB during power up of the laser or simply ensure Lightburn was running before I switched the laser power on…I chose the latter to avoid USB socket wear.

Hope this helps in some way.

John, Yes I have made the necessary corrections to the machine settings. I appreciate your input, thanks.

Did that fix it? If I had this problem I wouldn’t know what you did… what did you do?


Jack, once I got it to “home” it homed off the table a little bit as I had mentioned. My guess is the limit switch for “X” was probably installed a little too far to the right and I was going to move it but after looking thru the machine settings in lightburn I changed the “X” home offset to 4.5mm and it “homes” to where I want it now. I have to level the bed next as well as figure out why when I pulse it there are sparks coming out of the wire connection of the red laser wire. Not at the tube but, inline on the red wire.

Not sure what you mean here…

When you lose a tube and probably a ground the lps can generate a very high voltage in order to try and get the tube to lase.

It sounds like that could be the issue.


The red wire has a connector between the PS and the tube.

As you can see it shot out of the back and marked the machine. Looks like it is not going thru the connector.

That doesn’t look good… Is that a factory connector?

The wire and the connector do not look like a hv connector… it’s also suspicious that the diameter of the insulation looks smaller before entering the connector…

This is a hv splice from Cloud ray…

It’s substantially larger…


No, it’s not good at all. It is a factory connection, that’s how it came. I will be ordering the cloudray connector. Thanks for the link, appreciate it Jack.

I’ve used these from Amazon… you need to know the diameter of the hv wire…

This is my voltmeter connection…