Challenges Using the RA2Pro on xTool S1 in Lightburn

Good Morning,

I’m trying to setup Lightburn with my S1 and the RA2 Pro and I’m running into some strange issues.

I setup Lightburn per the documentation on the Xtool site (including downloading and installing the config file) and I adjusted the laser/crosshair offset per the instructions on a flat piece of wood. I know this worked because I ran a test marking a dot on the wood. I placed a crosshair on the dot and drew a 1mm circle on the canvas. I then sent the fire command and the laser head moved properly to burn the circle right on my dot.

The lase seems to function properly when in standard flat mode. If I use the detect function, the laser head drops and it auto detects the distance, the laser then moves to the back right corner to reset the sensor.

So per the above, everything seems to be functioning properly.

When I try to us ethe RA2 Pro everything goes haywire.

I start by enabling the rotary per the instructions and entering the GCodes. The following behaviors are observed at this point:

First Odd Behavior: If I click the “test button” in the rotary setup, the lase moves on the y and x axis drawing a rectangle and the rotary does not move. If I go ahead and click the Rotary framing button then frame, the rotary moves and the laser remains on the x axis. If I go back to the rotary setup and click test, it will now function properly, rotating 360 degrees.

Second Odd Behavior: When I set the distance, the sensor drops as normal, and the laser lowers to get a reading. The laser then moves along the x axis only straight to the rail and attempts to drop and reset the sensor there. It does not go to the back right corner as it should. The first time I did this my alignment laser was still attached to the RA2 Pro and the laser head hit it, I’m luck there was no damage.

Third Odd Behavior and the BIG Issue: When I lay out the image and frame, everything seems to rotate and work properly, no visible issue that is immediately recognizable. The crosshair is lined up dead center at the top of the cup and everything looks good. Fire the laser and the cup starts to rotate however, the laser head never moves on the y axis to put the laser aperture where the crosshair was. Instead, the laser only moves on the x axis firing about 2 cm off center of the top of the cup. I tried experimenting with the offset and it seems changes there adjust the rotation of the cup and starting point not, the laser’s y position. It always fires about 2 cm off center.

Any help would be appreciated.


I’ll check to see if we have some availability to test.

I’d like to know which version of LightBurn you’re using and confirm that you’re using the Windows 11 device.

If you have a link to the S1 setup you used, that may also be of assistance.

Thank you for the reply. I am using a Win11 device. I’m on the latest trial version of Lightburn, just downloaded it yesterday. 1.4.05

Here is the link to the setup file I downloaded from xTool:

From this page:Operate xTool S1 with LightBurn - xTool Support Center

Thank you,

1 Like

I’ve checked and we have yet to receive an xTool S1 for testing.

Linking the xTool S1 docs was very helpful. Thank you.

xTool Mentions a need for a recent firmware version.

Ensure that the firmware version of xTool S1 is larger than 004.

When you first connect to LightBurn, the firmware version number is sent from the engraver to the computer. It will appear in the Console window in LightBurn. The text in the Console window can be scrolled. Please Scroll back in that window, Select and Copy the text with the firmware version number, and Paste it into a reply here.

xTool seems to add nonstandard features (requirements) without letting us know. Hopefully the haywire behavior can be addressed with a firmware update.

Good Morning, I’m copying everything from the console window as I’m not exactly sure what I’m looking for.

Waiting for connection…
Waiting for connection…
USR [plugin_sd_card.c:139] f_rmdir logs_last.txt, ret 0
USR [plugin_sd_card.c:252] f_rename src logs.txt, dest_name logs_last.txt, ret 0
M2099 V40.32.007.2224.01 B5
M53 C0
M53 C0
M15 A1 S0
M1109 A-0.240 B21.720 C-0.315 D20.681 E58.000
M360 S1.500
M360 S1.500
M116 X0 Y20 B0
M1098 “”,“V40.201.009.3024.01B1”,“V40.208.001.3D28.01 B13”
M110 X1Y1
M222 S1
[xTool S1:ver V40.32.007.2025.01 B6]

From the XCS Software I see This:


When I attempt to update, it responds that I’m on the latest firmware.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.