Changing direction of "Y" axis

I forget how to change direction of the “Y” axis.
Forgive me. I will blame my absent mindness on having both knees replaced in July.

Have you checked this?

I am on a CO2 Laser

I suppose it depends on why. If your images are flipped because the origin is wrong then you need to change origin like Willie suggested.
If you’re trying to physically change the motor direction for everything then:
Edit > Machine Settings:

1 Like

I am all screwed up now.
“X” and “Y” both crash into stops. Both X and Y are set like this image:
Screen Shot 2021-06-11 at 3.54.22 PM

I should add: Direction Arrows on Laser move in correct direction

Screen Shot 2021-06-11 at 4.21.07 PM
Isn’t the green square dot supposed to be at bottom left, where it is. Red square dot should be in upper right corner, correct?
As you can see from screen shot they are both in lower left.

Ah, if the direction arrows on the controller are correct then don’t mess with the machine settings.
Sounds like you need to move your origin to a rear corner. Which corner does yours home to when you first start it? That’s where you usually want your origin.

image

My machine is left rear, but I hear many ruida based machines are right rear.

If you have a DSP controller, like Ruida, Trocen, or TopWisdom, common in larger CO2 lasers with metal cabinets and LCD displays, the origin corner will be the corner that the laser head seeks out when you power it up. With DSP controllers, the controller will automatically home itself when powered up, so you will not see the option for homing on startup.

Origin

This is the origin corner or 0,0 location for your laser. If you have a GCode based system, this is almost always at the front left, regardless of the location of your limit switches.

If you have a DSP laser, like Ruida or Trocen, the origin is usually where the limit switches are placed, and will will be the corner the laser seeks when powered up.

If your laser output is mirrored horizontally or vertically, move the dot to the opposite corner, horizontally or vertically, depending on the direction that the output is mirrored, and that will correct it. - Device Settings - LightBurn Software Documentation

My “Home” is top right
Origin is left lower
When I start machine it goes to home and then origin as it should
What I don’t remember? How to move red dot back to upper right corner
I am not in shop, will need to get back to it in the morning.
We had a power outage this afternoon while I was setting up machine. Didn’t seem to effect either the Laser or computer. LightBurn was open when that happened. Only lasted a few seconds.

Run LightBurn, go to Edit > Device Settings, and move the ‘Origin’ dot to the top right:

image

Also forgot to give you specifics
Omtech 60W, Ruida 2442G-B
Mac mini, Mac OS BigSur v11.2.3
LightBurn version is two behind present version. Sorry, don’t remember the actual number.

2 Likes

That’s ok - in this case, the change is pretty standard, and your profile tells us you have a Ruida 6442, so you done good. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.