Chinese 80W Water Leak flow sensor Failure (update)

Update from previous Topic, machine wont ulse. Item closed August 4 th
JK Willborn ,Dean448 for your interest…

Recieved my white orginal water flow sensor from China 1 month after order, installed and included Ice Cube Maker and water pump for water temperature control. tested machine and can now get a pulse, laser moves on x and y axis with pulse. created small test program 2 inch square with TST and sent message to laser, initially laser would not respond, message read water low sensor, shut down laser and retried. sent message to laser, and pressed Run, laser worked and engraved TST but would not cut through, restarted program and laser would not run. Message Water Flow sensor, also machine wont Pulse now. any ideas, this seems to be a common problem on Chinese laser looking at Youtube many different ideas about cause… Sam Midgley

Go to Z/U → Diagnostics on the Ruida panel and see if the flow sensor is working. It will display the state of the input. Turn you coolant on and off, it should follow.

The Ruida won’t let you run if there is one of the protection inputs active.


Hi Jack Ruida is showing a red dot beside water protect, I assume this means its on, turned chiller on and off could not see any difference.

Something isn’t working. You might try back up a level on the controller and go back to diagnostics. There is a button to re-read it… might try that. Which sensor did you purchase?


the original one from the manufacturer in China

why did it allow me to run and cut a program, even though it just lightly engraved not a cut through

went back on Ruida and tried everything but could not read file,

The tells me absolutely nothing.


Oh Dear, what next,I am baffled there must be someone out there that knows what to do!!!

Give us the link to the part. We can look at it.

The Ruida will run until it gets a wp error. It was not lasing with that error. So it sounds like it’s an intermittent, that’s why the query of what switch, and why you answer is useless. You have a technical problem and we need technical answers not vague ones…

Make sense?


Makes sense Jack but I am not a technical person when it comes to Laser machines, all I can tell you is what happens when I installed a very simple part, a flow switch, I have tried three different parts all flow meters, and all the same problem. Back to the start, Machine running and cutting ok, spotted water leak on the floor so started an investigation, water was leaking from the inlet side of the white plastic flow switch body, removed part and purchased another from Laser supplier in Melbourne similar switch with two wires, reconnected to laser with two wires, no leaks at this stage but alrm came on and laser would not pulse, this has been the only problem since failure, but continues to haunt me, since then ordered the original part from a supplier in China 1 month back, the water came from a CW3000 cooler purchased at the original sale, ( wrong one as it was only a cooler not chiller) so to go the cheap way as shown on Lousiana Hobby Guys program theis seemed to work well, so purchased Ice Maker for $100 and added a swim pool pump, problem solved as far as temperature can be controlled at 18 to 21 Deg C all day long. back to the Chinese flow meter, received from China exactly the same as the original part, installed and here we are today. Ruida showing machine stalled because of water protect issue, cant open Diagnostics as requested only shows red dot alongside, anything else you think I might provide, appreciate your help and patience. Sam

There was another user here that had a problem with a flow sensor because it wasn’t getting enough flow due to a restricted hose not allowing enough water to trigger the sensor.

Are you able to test the switch to make sure it’s triggering properly? If you’ve gone through 3 sensor there’s either something wrong elsewhere on your machine or the sensor isn’t getting an opportunity to work correctly.

Hi Berainib… you have probably read my post recently, so you will know this was a simple water leak , I have since tried three water sensors and all giving me the same results, Ruida saying water fault any help appreciated. Sam

Can you take a photo of the actual error on the panel?

Do you have a meter that you can use to test the flow sensor in isolation?

Is it installed backwards? The water needs to flow a certain direction

No Its definitely in right direction arrow on part

No dont have a meter

what kind of meter do I need, arrow on side of flow meter indicates direction

A typical multi-meter would be sufficient. In this case anything that could do a continuity test. You just want to be sure that the sensor is indeed being triggered with flow. If it is, then the problem lies elsewhere. If it isn’t then you know for some reason the sensor isn’t working. Either a bad sensor or something wrong with the delivery of water.

here is some more info