Chuck Rotary steps aren't changing the rotation

Chuck Rotary setup.

Guys, anyone had a issue when changing the steps for the rotary it didn’t end up doing a thing when changed to a different figure?

So I’ve drawn a rectangle, 20mm x 100mm and set the circumference of my object to 100mm. ( This is just a test procedure as my images were coming out stretched )

Technically, the Chuck rotary should make 1 complete 360degree rotation on the length of my rectangle stop and come back to the same point ? But Mine is going passed the start point every time it should have done one rotation.
Yes I know it is the steps, But when ever I adjust the steps, 12800 - 10000 - 8500 - 4000 -360 Nothing changes when doing a test?

How do I fix this ?

Check out this post, general rotary setup… if you still have issues… sing out… :crazy_face:

Good luck


Haha Thank you for this. Like I say, adjusting my steps doesn’t do anything. My rotary switches config say 4000 steps. If I set that, I get the same outcome as 12800 or any other figure I input…

I will assume you are using the Y axes and I’m not sure of what type of rotary you have belted or direct drive chuck. Also you can configure the 6445 differently than the 6442 (mine). Which Ruida is yours?

Both hardware and software need to be ‘synced’, so to speak.

If we separate them, the hardware or motor driver steps/rotation are known because they are set in the hardware. Since it seems to be working I will assume the motors will work …

If you are swapping out they Y axes, original working motor on Y indicates hardware is ok.

I think the motor drivers are ok. That leads us back to the controller configuration.

If it thinks it’s the rotary, it should correctly move it, if you have the steps/rotation incorrectly, it will still move it, just the wrong amount. An adjustment in steps/rotation should be seen especially with a 10% change…

Sounds like It doesn’t think you have a rotary.

Can you screenshot the rotary configuration and let us know which Ruida you are using. Also if it’s the Y axes you are using…


Hey there,

I have the 6442G controller, connected to the Y axis ( Says A on lightburn ) The switches are configured and stating the steps should be 4000… but like I say no matter the change that I do, it doesn’t effected the steps when using the rotary… The manufactures have confirmed that the steps need to be 10000, but even then it doesn’t change the steps.

If you are using the Y axes, it should be on the menu. You are probably not enabling the rotary.

I find no information of any kind for the 6442g using an ‘A’ axes… I didn’t think Lightburn shows options that are not available to your machines controller… I know I can’t select it on mine, it’s grayed out.

If you go back to the 2nd post with the link, you will see my rotary setup. I have a 6442g, so you should see a Y axes enable… If it’s set to A that’s a problem…

Is the Y axes ‘option’ not available ?

Makes me question why you would select A when you know it’s on Y…?

Is that your honeycomb bed in the photos? My electronics are in a partitioned area with it’s own access cover. Seems like a strange way to setup the electronics…


I am most certainly enabling the rotary, Y is not available only A is. I do think this is wrong but I have no idea how to fix this?

I switch over some wires today from the Y axis to the U axis as that was apparently the fix. What that being said, once I rewired it, the rotary never worked at all, the machine thought it was moving, but it wasn’t.

Yes that my honey comb, that image is the switches on the rotary.

I haven’t seen a Ruida setup properly that displays the A axes for a rotary. As far as I know this is an indication of your problem…

Maybe @JohnJohn has a clue about what could be configured incorrectly. Since we have the same controller I’d expect to see the same menus. I don’t think moving it to the U axes will do anything for you there is some kind of root cause for this…

You seem to be for the A axes… So I don’t know where this would be in any kind setup, as there is no mention of the A axes for anything in the Ruida manual…

Hang in there, lets see what the lightburn people can suggest… They’ve deal with lots of these…


Man I tell you I just need some progress.
Quick one, when you connect your rotary, is that it done hey once the steps are synced? all that changes is the objects diameter? I spoke to thunder themselves and they making me re wire this and that - I eventually lost my cool because I am the client not the service man looking for these issues.

They then gave me new parameters to try but that completely effected my Y axis. They said that way when I use the laser I got to revert back when I use the rotary I use those settings, that doesn’t make sense to me…

I hope someone knows what is wrong

You should not have to change the hardware switches to make this work. If you do, you won’t use it much.

Think of a rotary as your Y table wrapped around a tube… this is all that it’s doing.

The software has to ‘know’ how many steps to make the ‘motor’ rotate one revolution. This is the basic start point determined by your motor driver hardware settings or switches. I don’t know what type of chuck rotary you have, so it complicates this a bit.

  1. Chuck is directly driven by the motor.
    Enter this steps/rotation in the Lightburn GUI.
  2. Chuck is belt driven from the motor
    Apply the belts ratio to the motor driver steps/rotation and enter that in the GUI.
  3. Test button should work.

It is now configured digitally to the output of the motor. There is nothing here to adjust.

Only if you have a belt driven chuck is there a ‘fudge’ factor that may be needed, since the belt drive is ‘analog’.

Did you ask the laser support people an option for the ‘A’ axes on your Ruida? … which doesn’t have an A axes that I am aware of…

I noticed that both of your motor drivers pictured, have different settings… do you know why? Are they different motors? My motors ran real hot and I found they current settings on the motor driver was higher than my motors were specified. I cut that and now the motors run only warm to the touch.

With no details from what the support people told you to do, I can’t comment too much. Are these people in China or in your country? You shouldn’t have to redo the hardware to change to a rotary… It’s bad enough swapping a connector… like I have to do.

If you want dependability, you don’t reconfigure hardware back and forth… someone will make an error and it will cause a problem… this can be as simple as a single switch… It’s tough enough to keep the software end of it straight.

I hoped @JohnJohn would drop by and enlighten us on the ‘A’ axes issue and a Ruida. I think in the end, this is what will fix this beast. I don’t think you are properly engaging the software …

Good luck


Alright so let me know if I am on the right page here okay.

My measure the diameter of my chuck on my rotary and it comes in at 80mm. I then put a red dot on the top of it.
I go onto light burn, Set the object diameter to 80mm thus giving me around 251mm to be a circumference. I then Draw a rectangle, 251x20 and frame it…

right, in my brain, it tells me the rotary chuck should rotate 360 degrees ( one rotation ) from the point, to the point and then back because it is doing a full rotation around a 80mm circle right? Well my rotary spins 2.5 times and then comes back 2.5 times…

now Say I scale this down. I make my shape 100x20 and set the circumference to 100. The laser rotates passed the point, slightly but still. Which clearly highlights the steps aren’t correct?

hence my whole back and forth trying to get what ever I input to perfectly rotate.

These are people from China haha and damn It is hard getting through to them.

For the moment, forget the diameter, and drawing squares… lets ensure the hardware is set up properly.

This setup has nothing to do with diameter, so forget that until this is worked out. Diameter can’t/won’t be used until this is setup correctly.

  1. Which type of chuck rotary do you have is it direct drive or belt driven? A link is nice, so I can see it’s physical construction.
  2. What is the steps/rotation (hardware switches) of the axes in use?
  3. Can you select the proper axes in Lightburn gui for the rotary. If it’s the Y axes can you enable that?

I need your help to help you … settle down and relax… Hopefully you can understand what I trying to to here…


  1. It is belt driven.
  2. Steps with the switches is 4000
  3. I am unable to select Y - A is only available.

I think this is the problem… I assume it connects as a Ruida…? I know you are, just have to ask… I don’t think you should get an A option.

Thanks for the link to the rotary. It is belt driven, so you need to know the ratio of the motor to the chuck. That should have been available from the manufacture/vendor. You can measure them or count teeth…

On mine, the ratio is 2.5 to 1 the motor needs to rotate 2.5 times for the ‘wheel’ to rotate once.

You 4000 steps/rotation needs to be multiplied by the ratio… so the ‘chuck’ will rotate properly with the test button…

Make sense?

I’m trying to get the hardware end of this working, hoping someone will hop in and advise us about the A axes problem.


Make sense?

I went and looked at my engraver and there is a three-pin XLR type of connector in the back left corner just under the corner of the lid that connects the Y-axis motor to the stepper driver.

To use the rotary on mine, the Y motor is disconnected and the rotary is plugged into that stepper driver.

I have no Z-axis driver connected but there is a provision on the controller. A clear shot of the controller could help get us oriented to what’s going on.
Ruida 6442 cropped

The gui only has an option for the A axes for the rotary… I have not see an A axes mentioned in any of the Ruida documentation or manuals.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.