Chuck Rotary tool setup

For setting up the Ortur Chuck Rotary attachment the homing must be turned off with the $22=0 cmd. Next is the $141=600 cmd. What does $141 do? If I look at the Machine Setting function it shows $141 as the Y driver current amps and shows 5.000. A video I watched said $141 was for backlash adjustment. Can anybody tell me what it’s really for?

$141 is for setting Y-axis motor current.

Ortur lists this on their firmware site.

Here’s a direct link to the full document:
GRBL Settings OLM3_210.pdf (

Was that video for Ortur or a different machine. $141 was not defined with the original GRBL implementation so all of these are non-standard uses.

The video was for the Urtur LM3 and the Urtur Chuck Rotary tool. That’s what I found also, $141 didn’t seem to be defined. BUT - “IF” you look at “edit - Machine Settings” box in the selections down toward the bottom you’ll find a “Y driver current amps” box that is $141. Is it ok to post a link to the video I saw?

The descriptions in Machine Settings are, I believe, provided by LightBurn. In this case, not sure if LightBurn is providing specific information for Ortur’s implementation or if it generically assumes that all $141 is meant for Y-motor current. Some versions of GRBL will include descriptions for the configuration as well.

Sure. Post the link.

1 Like

Thank you for the response. Here’s the video

At the 10:50 mark he mentions the “backlash”. As new as I am with this stuff it leaves me all confused.

Ken H>

A few possibilities:

  1. He simply misspoke
  2. $141 used to be used for backlash but has changed. This seems unlikely but it’s possible. $161 is Y-axis backlash compensation.
  3. He goofed and misremembered

I don’t see why a chuck rotary would have any more backlash than other systems. In fact, I’d expect it be less than a belted system.

Note that the value he enters (600) would be appropriate as a current value in milliamps but wouldn’t be appropriate as a backlash correction in millimeters.

Thank you for sharing your knowledge. I agree I can’t see any reason for backlash adjustments. Now, on the values that Ortur recommends, $141=600 to operate the chuck rotary, and $141=1000 to operate in normal fashion. why should the Y current requirement need changing? Also, why does lightburn show the Machine Setting function as $141 as the Y driver current amps as 5.000? This is a value that is read from the machine. Like you I would have expected the value to be expressed as mA.

Boy, this laser stuff is keeping my old brain exercised. They say us “old folks” need to keep the brain active.

The stepper motor in the rotary is likely different than the one used normally. Different stepper or application, different requirements.

I missed earlier that there was a discrepancy in the value. Can you take a screenshot of this? There are times where LightBurn will show simplified versions of settings which leads to different ways of showing values as compared to $$ output. I don’t know if that’s what’s going on here. It may also just be a bug but let’s confirm.

Some would run from any perceived complexity but it seems it’s just sucking you in. Good on you. You’ll find that it’s not necessarily complex, just a wide range of relatively simple concepts but sometimes hard to find what you’re looking for.

I’m always looking for fun things to do, from working with Arduinos to using FreeCAD to draw up a simple project for the 3D printer. I also make custom knifes, Damascus and kitchen knives. This is a dagger I made a while back:

OK good. I wasn’t sure about pasting from clipboard to the forum. Seems to work good. As you can see the $141 shows 5.000. Even with the $141=600 when the “Controller settings read successfully” is complete it still shows 5.000 as the value.

Odd indeed. It could very well be a bug. I recall someone else noticing something similar sometime back.

@Rick @JohnJohn @Colin Adding some LightBurn folks for potential insight.

This may be a bug, or it may be because Ortur is using a non-standard GRBL Will bring up with our devs

1 Like

So the units display in the Device Settings window is provided by LightBurn and is no longer attached to the units of the actual machine providing the information in GRBL 1.1 onwards. This is because the descriptions were removed from the firmware to save room on the flash of boards for more features!

So at this point I’m not positive if Ortur is using mA or A - it would appear amps.

Please do a $$ command in the Console and check the result for sure. if they’re not returning the units (in brackets) then we have to assume the “default convention units”.

… which is even harder for $140 because it’s a non-core GRBL command, I can’t even find what the “default convention” for it is.

Their documentation lists mA and defaults to 1000.

This is definitely not one of the original GRBL config values. I believe it was extended in grblHAL. Not sure if other implementations have adopted the same convention.

1 Like

I just did the $$ cmd and it returns “$$141=1000” with no units showing. So, I’d “assume” it to be mA, even with LB returning 5.000 on the machine settings.

BTW, when I enter $$ cmd to see all those values, how do I get back to normal operation? The console screen never returns the “ok”, and the laser shows “busy”. Only way I’ve found to keep working is to close LB, and restart. Surely I’m missing something? Even “ctrl-c”, nor “esc” will return the “ok” so I can continue.

1 Like

I concur. The software comments state the units in grblHAL are Amps - Ortur using milliamps seems pretty reasonable.
From config.h core/config.h at b6e43d6c194fa0f830ff3987a4aa1cd78b310dd6 · grblHAL/core · GitHub

2023-04-21_14-53-19 stepper current

While I’ve got so many really smart folks on this thread, how about the 2nd part of my post?

BTW, when I enter $$ cmd to see all those values, how do I get back to normal operation? The console screen never returns the “ok”, and the laser shows “busy”. Only way I’ve found to keep working is to close LB, and restart. Surely I’m missing something? Even “ctrl-c”, nor “esc” will return the “ok” so I can continue without having to close LB?

That shouldn’t be the case so not sure what’s going on there. If you start with a brand new session and literally only push $$ followed by the enter key, this occurs?

If so, that implies some sort of other communication issue.

Can you take a screenshot of Edit->Device Settings?

1 Like

When I just now tried the $$ cmd with LB first started it worked ok, and connected with WiFi.
edit to add: When opening the “edit - Machine Settings”, the dialog box reads the machine and looks good. If I then ask it read machine again, I think get the Communication Failed msg and the Machine Settings box is blank, but the values all appear in the console window ending with (serial speed, IP, etc:

Here’s the screen shot for “edit-Device Settings”:

Yes, you’re right, it does seem like there are some “communication” issues. Now I think I see when the problem occurs. When I open “edit - machine settings” and the machine settings are successively read, everything is ok. If the reading fails, then the machine stays busy and I have to close program and restart. Everything works good if I don’t try to read the machine settings via the “edit - Machine Settings” option. If I do and it reads - good. If it doesn’t read, then machine stays busy requiring closing program and restart. If I issue the $$ cmd from console, everything seems ok. It’s only when trying the “edit - Machine Settings” option.

It does seem to work more consistently on USB than on WiFi. For normal use the laser works good on WiFi, just when playing with these settings does WiFi seem to cause problems.
Again, thank ya’ll for all the help. Talking (writing) with yall and working thru has helped me with a better understanding.
Ken H>

Interesting. Perhaps a generalized problem with reading Machine Settings on that machine and the $141 value is related. Not sure.

I know there have been growing pains with the WiFi connection on OLM3 with most issues being worked through but perhaps still some gremlins left lurking.

If this is the biggest gremlin I have in a software, I’m happy. Not a problem to work around. Thank Ya’ll for such a nice software program and for all the help.