Circles are cutting rough after latest update

i can only imagine HEHE

so, mechanically everything seems to be sound. he did a reset default params at the controller level and tried rdworks with acceptable results. any other suggestions?

I do subdivide differently than RDWorks does - adjusting the curve output tolerance could help, but ultimately what makes more sense is choosing a speed that the machine is physically capable of so it’s not constantly trying to accelerate / decelerate on straight bits and shaking itself to death.

Are you running the same machine with the same settings as him? Check the curve tolerance value on yours and make sure his is set the same. Other than that, it’s machine settings only that control how the job runs.

this is from the OP’s machine. they only real differences from my settings (aside from bed size) are some of the e-stop accelerations but not sure that is even a factor here

And what is his curve output tolerance compared to yours? (In global settings)

finding that info. there is this as well:

curve output tolerance 0.005

0.005 !? That’s in mm. You’re fire-hosing the controller with node data.

This number is the maximum allowed deviation from a curve when sending line segment data to the controller (they only accept lines). The default is 0.05mm (50 microns), which is about 1/2 the kerf width of a CO2 laser. 0.005 (5 microns) would be used if you were machining engine pistons for NASA. :slight_smile:

To show the difference, this is what LightBurn would send to the machine for a 1mm diameter circle with your curve tolerance sent to 0.05mm (left) and 0.005mm (right):

The one on the left is 16 nodes. The one on the right is 84. Set that back to 0.05mm and things should go a lot better.

Note, this is what they look like at actual size:

1 Like

This is the image from before the update. So your are saying the curve tolerance should be 0.05 mm not 0.005. Could running the rotary attachment earlier this week have caused this to change?

Rotary won’t touch that, no.

I’ll double check to make sure I haven’t done something stupid like mess that up when you flip between mm / inch mode, but that’s the only thing I can think of that might affect it other than directly changing it. It should be 0.05. My life would be so much less complicated if everyone would settle on one unit. :slight_smile:

the highest the number will go is 0.01969 mm.

Ok, that’s probably an inch / mm thing. I’ll fix. It might actually be correct, and just showing (mm) there because that’s how it’s labeled.

Ok, the control itself is actually reading inches if you are in inch mode, so the 0.005 value is inches, which makes it 0.127mm, so it’s too high, not too low. The curve tolerance control doesn’t have its ‘allowed range’ adjusted properly when you’re in inch mode, so it’s clamping the inch numbers to mm ranges, which is screwing things up. I’ll have a fix in a few minutes.

Oo ooohhh can we go with light-nanoseconds?!

I’ve always been partial to parsecs per fortnight, myself. I’m altering this specific control to just always read in mm, as the numbers get really small in inches anyway.

A little unconventional, but I’m sure we’ll all adjust to that unit of measure.

It makes the cut settings a little harder to keep track of - Was it 0.0000000000000000000000001, or 0.000000000000000000000000000000001 that I used for birch? I can’t remember…


So he went back to mm/sec and was able to change to 0.05. Test cut okay. Then switch back to inch / mm/sec and the settings stuck. It smoothed out.

Got it!!! Brian will explain more. Thanks for your help!!! If I understand correctly the issues is in the inches/mm/sec…I need to use mm/sec. When I use mm/sec cuts are perfect.

Yes, I’m fixing the curve tolerance control so it just stays in inches all the time.

You won’t have a problem with it even if you run in inches as long as you don’t open the settings in inches - It’s when you go to the settings page and it tries to enforce the limits on that number that it’s messing it up. I’ll have a build up in a couple minutes and can send you a link with the fixed version.

1 Like