CO2 Laser using Ruida RDC6445G Controller

Hi Guys,

Just completed my own CO2 Laser build, using SPT 100w laser tube with Ruida RDC6445g controller, issue i am having is the laser wont fire using pulse on the LCD panel of the controller, however when i remove the connection block from the main board where motors are connected etc i can get the laser to test using the test push button on the power supply. This leads me to a connection or paramater issue. i followed the wiring diagram from cloudray, Power supply IN to pin number 5 on Ruida, Power supply G goes to pin number 1 and power supper L to Ruida pin number 2. Am i missing something here ? i havent installed Lightburn yet but i should be able to use Pulse on the front control screen ? please advise thanks in advance

There are also multiple supplies, generally referred to as the laser power supply or lps compared to the power supplies for the 24v and/or 5v.

I think I get your drift, to be clear…

L-AN2 is the analog output of that controller. Although the lps should work with an analog signal, most are, like mine here, connected to LPWM1 which is the digital pwm.

Let’s go elsewhere

Exactly which connections are you referring to?

Will the test button on the lps fire the laser under all circumstances?


Hi Jack

Thank you for the quick reply, i believe i may have figured out the issue, i forgot to add the water flow sensor and this maybe the reason the laser wont fire via the controller. I have ordered one this evening and hopefully this will solve the issue. Really appreciate your input thank you. i will update the post if it works.

I notice you are using pins 1 2 3 and 4. i take you are using a water flow sensor in your system ? however, on cloudray wiring diagram it is using pins 1, 2 and 5 excluding flow sensor

Turn the ‘water protection’ off. This means you are responsible for ensuring water flow.

‘Edit → Machine Settings → Vendor Settings’

This can be changed from the console too.

Unplugging the connectors would have anything to do with water protection.

WP active would be displayed in the machines console as a ‘wp error’ or something similar.

This scares me as you shouldn’t be running this without an kind of coolant flow…


Hi Jack

I am using stand alone chiller not rooted through the controller. When i have the connector connected to the LPS it wont pulse via the controller, however when i disconnect and hit test on the LPS the tube fires, that lead me to believe it was a communication issue. I will try disabling the flow sensor as you mentioned thank you. I know it is something simple and great to get the advice from yourself.

If it’s the flow sensor, you should see it on the console. My Ruida beeps at me I think, like when it boots.

Lets look at how that connector is wired, it that’s ok.

The only wires needed are ground (pin 1), LPWM1 (or probably L-AN1) and L-On1.

Ruida → lps
LPWM1 → ‘IN’
L-On1 → L - *

In the previous post with the Machine Settings, there are Laser 1 Output. I think these control if your pwm signal is inverted.

  • the ‘H’ input is for L-On1 going ‘high’ instead of low.


My connector is wired like yours Jack, only thing i dont have is the water flow sensor connected, i cannot find the vendo settings in the Ruida RDC6445G controller. When i hit pulse via Ruida LCD panel i get the green light on the LPS. I went through the menu for machine settings and nothing there to bypass the WP sensor

I think you have to get into the settings that require a password.

Change it via Lightburn

Pin5 of cn5 is the L-AN1, or the analog output. I use Pin 3 or LPWM1.

They are not wired the same…

I think it should still work.

The screen shot I posted of the Machine Settings has to be there…

Did you click on the ‘Vendor Settings’ to expand that tab?


Hey guys I have a Chinese built laser it’s an HL 1060 100W. I have the same issue if I disconnect the signal output connector and hit the test button on the power supply the laser fires. I use a cooler with mine and the laser has worked with no issues until recently. So I’m not sure what to check based off these results. I did check the emergency stop button and the sensor to make sure the door is shut they both passed. Anyone else have any ideas?

Did you get the machine up?


You need to mention what the Ruida controllers display is indicating.

If it’s in an error condition that’s different than if it thinks it’s ‘running’ and it’s not.

Generally these operate pretty simply from the signal standpoint. I gave the connections on a previous post.

Do you have a way to check the signals? Scope or voltmeter…


The controller shows normal. I have a voltmeter but not sure what needs to be tested. I’m pretty new to lasers and I’m at a lose on what needs to be done other than some info I have been able to find here and there.

You will have to give me more help.

If it’s wired like I mentioned, then the ‘L-ON1’ goes low to enable the supply.

When the ‘LPWM1’ goes high the laser should fire.

You should be able to measure the voltages at the power supply or on the Ruida.

At 50% pwm you should be about 1/2 the ttl voltage or 2.5 volts there abouts. You shouldn’t need the lps powered up. The ‘L’ pin needs to be low during the firing.


First of all thanks for the help you have provided so far. I found some information on the internet and it suggested trying to move the cables from CN5 to CN6 to see if this resolves the issue.

So after performing these steps I was able to pulse the laser with success from the Ruida controller and it works with no issues. The problem is LB does not fire the laser. I have tried messing around with the settings in LB as well as on the controller to get it to fire with no success.

Now not understanding this I’m not sure what if anything that tells us might be wrong with the laser but I feel like there may be a setting I’m missing to get the laser to fire in LB. Any advice?

Hi Joe, is your LB looking for a signal from the water flow meter ? i take it the CN5 and CN6, i am building a new machine and i noticed i can test fire the tube from the power supply and not Ruida controller because it has a built in safety for the water flow meter. I will be installing the meter this weekend and let you know if this is a fix. I could be wrong and stand correct :slight_smile:

Thank you for the advice I’m not sure that is the issue. The only reason I say that is because I had my water flow reversed and I was not able to pulse the laser prior to correcting it. I could be wrong though as I’m no guru when it comes to the laser. I would imagine LB would use the same sensor as the laser and since I’m able to pulse it from the controller directly now I would think it is detecting the water flow. Honestly I’m not even sure what sensor it uses though so take my comments with a grain of salt…:slight_smile:

I wanted to add prior to changing it from CN5 to CN6 I was able to pulse the laser from the power supply as well but the controller would not fire until I moved it to CN6 once I moved this I can pulse the laser directly from the Ruida controller.

The only difference from CN5 to CN6 is the laser tube it controls. CN5 is the output control for Laser one and CN6 is the output control for Laser 2. Something must be hosed in the configuration…

Good luck


Thanks Jack I will keep digging for a solution. This is very frustrating it’s just hard to find much information out there about the lasers.

How is the laser 1 and laser 2 configured in your Ruida?

It might be that one of the signals are inverted…



This is starting to sound more like a wiring/configuration issue.

If the configuration is correct, I wouldn’t think it would be enabled.

Between the controller and the lps should be checked.


This is the settings I have.



Also just for reference on anyone having issues connecting from LB to the controller. I had this issue and as it turns out I have multiple vlans and was hardwired to my main lan and was able to ping the controller and everything from my machine but was not able to connect to the laser from LB until I connected to the same wireless as the laser.

This was the case even though the vlans are not locked down at this point. So no firewall was blocking any communications across any of my vlans at all. Just seen a lot of people having that issue and wanted to get it out in case anyone experiences a similar issue.