Comgrow Z1 Firmware Update Bricked My Laser

(Used) Comgrow Z1 was frequently terminating jobs before finished. I tried new USB cable and grounding all the laser parts as many have suggested. I also fixed Windows’ helpful shutting down of USB ports at random. Laser began to stutter and crash into the side rails, so I tried updating the firmware. At that point is stopped doing anything at all.

Discovered that Laser GRBL could at least move the X and Y axis, but only if I changed the baud rate to 230,400 bits per second. Could not laser burn any files, but at least it proved that the USB connection was communicating between laser and computer. Meanwhile Lightburn is “still waiting for connection”.

Sad to report that Comgrow’s customer service in China is no help. They don’t answer my questions nor offer any suggestions.

1 Like

Currently, China is going through a holiday, probably back Monday. Unsure how long you been going through this with them

Doesn’t Comgrow use an MKS board? have you checked the web for update procedure, is possible you will need a bootloader too

For reference:

Yes, I followed their firmware update procedure to the letter. Nothing was said about a bootloader. I’ve been emailing them for most of the past week. Bottom line is this laser went from working poorly/sporadically, to working not at all.

Here is an update on this problem. Turns out that the latest Comgrow firmware runs at 230,400 BAUD, but my 7-8 year old Dell laptop can’t handle it. I thank Comgrow’s customer service in China for pointing me in the right direction. I do have a desktop computer that works with the latest Comgrow firmware, but I can’t take it outdoors to use the laser. I have a more modern Apple laptop that does 230,400 but for some reason it doesn’t connect with the Comgrow. If anyone has a solution to that problem, please post it.

Is this apple a M1 chip?
Try getting yourself a very CHEAP and dumb
USBc to USBa hub - black usb ports

that should help

1 Like

I think that’s really unlikely. I’m using a ThinkPad that’s more than ten years old, and even 20-year-ol PCs should not have a problem with that baud rate. 230,400 baud means 23 kbyte/s. That’s nothing. If the laptop can’t handle it, that should be a settings problem, I guess.

Finally, I figured out exactly what the problem was (past tense). Using a different computer fixed everything. In fact, I bought a brand new $300 Acer laptop from Amazon specifically to be used with this Comgrow Z1 diode laser. Since doing that, this laser has run for many hours with no hiccups. The USB baud rate was the problem with my Dell Windows machine. It simply would NOT accomodate the laser’s requirement for 230,400 baud. Comgrow never bothered to mention the new higher baud rate because it never occurred to them that such a problem was even possible. Normally the connected device calls the tune, and the computer cooperates - except in the case of my Dell laptop.
As for why the MacBook Air would not talk to the laser, I have no idea. I installed the required driver several times, but it made no difference. Mac OS was having none of it. Customer service from China was hard to get, but I did get it - finally. Comgrow has room for improvement in that department. They were more interested in verifying the status of my warranty than helping a customer solve a problem. The laser itself is what I would call a skeleton frame type. While the work area of this Z1 is specified a respectable 400 by 400 mm, the upper tight corner is effectively unusable, because the cable to the laser head bunches up when the gantry goes there. I dressed the cable as short as possible so that the laser head can reach the lower left corner, but it still flops over and interferes in the upper right corner. If you intend to engrave something that uses the entire 400 by 400 work area, you will have to make your own provisions to manage that cable.

1 Like

Comgrow Z1 died again. We’re back to the same issue. BAUD 230400 not listed as available on the computer. It had shown up when I bought a new computer and worked for a few weeks. Now it disappeared again. I know that 230400 is essential for communications with this Z1. Computer says the CD241 driver is the latest and is installed and is working properly. The latest problem happened when I went to shut down Lightburn. Software said I was still connected and did I want to shut down anyway? Well duh! That’s a silly question but I think it is coming from Comgrow, not the new computer. Find my laser finds nothing. Manual installation does not ask about baud rate at all. Only asks what kind of laser I have (GRBL) and the dimensions of the work area. Lightburn console is still “waiting for connection”.

i think this is preceding of software

Try this, as you are on windows

Right click windows menu > device managers
Expand the ports section with machine unplugged
Take a screenshot

Now power on your machine and plug usb cable
Take another screenshot.

Post both

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.