Comgrow Z1 - waiting for connection

Hi - new engraver here, and currently using a trial version off Lightburn, with my new Comgrow Z1 10w.

I have connected and printed using GRBL software, but dont like that, and looking at youtube videos, the recommended software is lightburn.

Howvere, I cant get Lightburn to talk to my Z1. I have installed (after uninstalled) the driver CH340, rebooted, turned off Z1, and restarted all. But the Z1 will not pick up in the find device. I know its there, GRBL can see it.

If i add in manually (under GRBL) then the Laser says ready, but under console ‘Waiting for connection’.

Have read thread changing the $33, b ut in settings, there is nothing shown, just a comment ‘Communication with controller failed’.

Any suggestions? Have been trying now for a few weeks, and my trial comes to and end soon, when I will have to make a decision to buy or ditch. I so want to buy, as it looks so much better

Can you provide the following?

  1. Full screenshot of LightBurn window making sure that the Laser window is visible
  2. In Laser window push Devices button. In the Devices list that comes up, click once onto the name of your laser. Take a screenshot.
  3. Screenshot of LaserGRBL connected to your laser



Hope these are what you are looking for. Thanks

Things look good from those screenshots. Can you take a screenshot of Edit->Device Settings?

Very odd. There was another user @TheCodeGeek that had the opposite problem from you. Worked in LightBurn but not LaserGRBL.

Perhaps try enabling the “Enable DTR signal” option in Device Settings. Also try variations of Baud Rate.

I noticed also that there’s a firmware update available but it looks to be the same as what you have from what I can tell.

Best Diode Laser Engraver Small Engraving DIY Machines Z1 - Comgrow Official Store

Have you tried rebooting your computer recently? Wondering if possibly LaserGRBL is not giving up the serial port.

ok - so really confused, after about 3 reboots it suddenly connects. No idea why…

But although it went through all the motions, the laser looked on - it doesn’t seem to have engraved anything.



I was trying to print a calibrations print, at different powers/stream. So wasn’t expecting everything to be right, but did expect to see something!!

Any suggestions (should i put this in a separate thread??)

That’s great that it now connects. Odd… but let’s take it as a win.

As far as it not marking the material I suspect your speed is just way too high. There are really only 3 factors in a burn: focus, speed, and power. Assuming your focus is good and your power is already at 100% then reduce speed.

On a different note, you may want to read this post about power levels and diode degradation.

1 Like