Conection issues AWC708S

Hello, I just recently bought a 50w Co2 laser with a AWC708S controller. I have used lightburn before with my GBRL laser so i’m familiar with the software. I can’t get Lightburn to connect to the controller it keeps saying disconnected. I was able to move the machine around using LaserCAD any suggestions?
I have looked at a few other threads and have not found a solution to the problem yet.

Thanks for any help!

Are you using the DSP version of LightBurn? The GCode version will not connect to the AWC, it is a DSP motion control system.

You can purchase an Upgrade from GCode to DSP here: LightBurn Software - Upgrade from GCode to DSP license

Im sorry. I should have included that in my original message. Yes I purchased the upgraded version for DSP.

OK, so then more details about how you are trying to connect, which OS, which version of LightBurn, have you ever had successful connection using LightBurn with this setup?

What have you tried, and what were the exact results? We cannot see what you are experiencing, so paint as clear a picture as you can to help us.

I’m running windows 10, Version 1.0.00 lightBurn. this is the first time trying to connect this machine to lightBurn. I have tried the find my laser function but doesn’t detect. I have tried the create manual tab with a USB connection and Ethernet Connection profiles and no luck. I have Deactivated my licenses and reactivate my licenses because in a previous email it said something about the licenses having to update the software after being upgraded from GBRL.

You may need to select the correct port from the drop-down to the right of the ‘Devices’ button. Best to ensure you working with a known-good USB cable as well. And to confirm, you did install LaserCAD to get their driver, correct?

2021-08-16 17_58_16-Clipboard

laserCAD is installed along with all the drivers. it works fine in LaserCad.
I Attached a picture of what it shows for me. Also I got it to move a few moments ago but the light burn crashed and wont move anymore. when it was moving it was still saying disconnected like in the picture.

Wait…its working now but when the files sends it does a straight line horizontally( left and right) and doesn’t appear to turn the laser on. it also doesn’t put the image or shape where its at in the program. but if I tell it to trace or frame it goes right were it need to.

Try this, power the laser first, then launch LB or right-click ‘Devices’ to reconnect. This should reset the connection.

Ok that seems like it’s working now thanks! It still says disconnected but it seems to be working. Last problem. What would cause my design not to be on the same spot on the laser bed as it is in the program? My table size is set correctly and I can tell the laser head to go to certain spot on the bed but when I send the program it goes somewhere completely different when the program starts to cut / engrave?

This is a known issue, still to be sorted, but the connection is valid.

Where do you have the Start From set?

‘Start From / Job Origin’

These two controls affect where the job is placed on the bed of your laser. Please read the Coordinates and Job Origin page for details on the different modes, and how they affect the placement of your job.

it seems to be working as it should now thanks! Sorry for the late reply. the machine was setting a origin position from another program and was not resetting with the new one. its all good now. thanks again for the help.

1 Like