Configure / Calibrate Z Movement

Maybe my mind is in a fog this evening. I thought I would go ahead and take advantage of Z movements with the new 0.9.10 release. They seem to work well.

My problem is my own problem. That is, I need to configure steps per mm / inch somewhere for Z (when I specify move 1", the bed only moves about 1/8"), but I don’t know where the setting is. The machine configuration, I have searched.

Ruida RDC6445G(EC)

Also, I did find this thread on the topic, but the step length setting does not get me anywhere close. Maybe I need to adjust my stepper driver.

The step length value is what you’d need to change. With a Z axis, they’re usually using threaded rods, so the Z distance traveled by a single step is very small.

You said that requesting 1" goes 1/8", so change the 8um per step to 1um and that will make the controller send 8x the number of pulses per move. You’ll also want to drop the max speed for Z way down, since it can’t move quickly, and the jumpoff speed should be low as well.

That’s what i was working with yesterday, but for some reason (most likely something I did wrong) changing the step length yesterday was not making much of a change.

So today when adjusting steps length, I could tell there was a difference. My problem now is that even at 1, the movement of Z is still short 20% (when specifying 1", I get .8" of movement). If I set the value to .9, the motors begin to sound odd and I get it move about .83 inches. If I set the value to anything below .9, horrible sounds await attempted movement of Z.

image

The movement with such settings:

Every time you lower the step length, the motor has to take more steps to go the same distance. If the motor sounds terrible when you lower the number, it means it’s now skipping, trying to go too fast, so you’ll likely need to lower the max speed, acceleration, etc along with it.

30mm/sec is still likely about 10x faster than most Z tables will move.

I think the issue is that my Z stepper motors are 200 steps per revolution (1.8 degree). My driver is set to 4000.

I’ll adjust my driver accordingly and get this tuned.

Problem solved! Just what I thought. I needed to adjust the stepper driver. I changed the driver to 2000 pulses per rev and adjusted the step length to 1.6. Now it’s perfect:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.