Connecting and communicating Laser JL3 with Lightburn

Yes, im a newbie. For about 36 hours now, Ive been trying to get my Wainlux JL3 to connect to my laptop and lightburn but nothing is happening. Please can somebody walk me through the setup process?
Ive followed the youtube videos, read articles, asked lightburn and wainlux for help. Nothing.
Please help.

I believe by default the Wainlux JL3 does not come loaded with a GRBL firmware. Wainlux does offer a separate firmware that can be used to flash GRBL to the machine.

Can you confirm what firmware you are running?

Will it connect to the supplied software?

If so you might be able to figure out what it’s running.

Good luck

:smile_cat:

No, I am not educated enough to know what firmware even is. Sorry. I dont know what GRBL is. I dont know what flashing is. This is all new to me.

Not sure what you mean by software. Im trying to use lightburn.

Most of these come with some kind of software supplied by the manufacturer so you can use it when you get it. Did it not come with some kind of usb stick ?

:smile_cat:

Yes it did. The instruction book did not come with clear instructions on what it was. I just thought it was for storing my art work.
There are no youtube videos on how to install the cables or how to even turn the unit on. Lightburn cant find the engraver.

LightBurn will be unable to locate the laser until the firmware has been changed to GRBL. Wainlux has guidance on this via a video here: How to upgrade LaserGRBL firmware – JL3-30W - YouTube

I’m going to copy part of my private reply via email here for other Wainlux users in the future

If you want to use the JL3 with LightBurn, you’ll need to load new firmware (GRBL) to the laser - You’ll want to follow the steps in the YouTube video here provided by Wainlux: How to upgrade LaserGRBL firmware – JL3-30W - YouTube

In brief: You’ll plug in the USB flash drive that came with the laser and open it up on your PC. There’s a folder called 'Lasergrbl", enter that folder, and then right click to copy the file ‘JL3_grbl.bin’, and then right click in the folder again to paste .

Right click the copy of the file, select ‘rename’, and rename it ‘ROM.bin’ - then follow the video’s instructions to turn your laser on while holding the ‘offline’ key and flipping the power switch to put the laser into programming mode. This segment here: How to upgrade LaserGRBL firmware – JL3-30W - YouTube

Once in firmware programming mode, run the file ‘Upgrade.exe’ to flash the new firmware onto your laser’s controller. Once the progress bar has completed, close the upgrade.exe program and power cycle your laser. Then, you will be able to connect to and set up your laser in LightBurn as a ‘GRBL’ device.

After this, we have a first time setup video for LightBurn you can follow here: Lesson #1 - First Time User - YouTube

Manager

LightBurn will be unable to locafirmware has been changed to GRBL. Wainlux has guidance on this

I’m going to copy part of my private reply via email here for other Wainlux users in the future

If you want to use the JL3 with LightBurn, you’ll need to load new firmware (GRBL) to the laser - You’ll want to follow the steps in the YouTube video here provided by Wainlux:

In brief: You’ll plug in the USB flash drive that came with the laser and open it up on your PC. There’s a folder called 'Lasergrbl", enter that folder, and then right click to copy the file ‘JL3_grbl.bin’, and then right click in the folder again to paste .

Right click the copy of the file, select ‘rename’, and rename it ‘ROM.bin’ - then follow the video’s instructions to turn your laser on while holding the ‘offline’ key and flipping the power switch to put the laser into programming mode. This segment here:

Once in firmware programming mode, run the file ‘Upgrade.exe’ to flash the new firmware onto your laser’s controller. Once the progress bar has completed, close the upgrade.exe program and power cycle your laser. Then, you will be able to connect to and set up your laser in LightBurn as a ‘GRBL’ device.

I got as far as the “upgrade”.
I went into UP_BLE_v1.3 to upgrade. The small window opened to start upgrade. I pushed the button on laser and powered on. Then i clicked “start upgrade”. The green bar went across but when it got to the end nothing happens. It has been 15 minutes. I clicked “start upgrade” again and another small window opened that says “No device found”. What should i do now?

If you don’t understand, please ask…

All machines run software… firmware is generally the software that runs the device internally. If you have a dvd player, it has a computer and software (firmware) to tell the computer how to deal with a dvd player…


I don’t care if your 7 or 70 … none of us learn by osmosis…

Good luck

:smile_cat:

I may have messed up. There were 2 files with the .bin i think i changed the wrong one. What should i do?
Yes, there was already one with rom.bin so i changed the name of the other one to ROM.bin.the

If there was already a ROM.bin I’d assume that to be the GRBL firmware. Else rename the one as per the video.

If you are concerned, I would contact Wainlux and ask for the firmware from them directly. It doesn’t appear easily found in my searching, similar to what this other user noted: JL1 (JL3) GRBL firmware avialable - #4 by LsrSal

I got as far as the “start upgrade” window. I pushed the button on the laser and powered it on. I clicked the start upgrade. The green bar went across and stopped at the end. Nothing. I waithed 15 minutes and clicked the start upgrade button again. Another small window opened that says “No device found”. What should i do next?
Oh, the “file” i opened to upgrade was UP_BLE_v1.3

It’s what mine did and that you can longer connect with their software means it probably upgraded…

You should be able to talk to it with Lightburn.

:smile_cat:

Do I just X out of upgrade and try it?

The upgrade process I did just did it… I had to just kill it. Then their software would not connect, but Lightburn would…

My machine is JL1, I think… but I bet it’s the same controller/firmware.

:smile_cat:

I think this is the same controller as the JL1 board that we dealt with in the $79 Cenoz laser engraver thread. That “upgrade.exe” program file is very minimalistic and gives no indication that it completed successfully… but if it also gives no indications of anything wrong, then it should be good. The progress bar usually appears to go to about 80% or so and then it completes so quickly as to not be seen/noticed and the window returns to its starting state. You’ll need to “trust” it at this point and move on to testing it to confirm.

Basically you’re hooking the Windows computer (with the “upgrade.exe” and “ROM.bin” files) to the un-powered controller board with USB cable per normal… and then you HOLD the JL1 button (between the USB and power connectors on the controller) while powering on the laser machine. That puts the board in “upload mode”. Run the “upgrade.exe” and a simple pop-up window with one button and progress bar… click the “Start Upgrading” button. Green progress bar starts and completes in less than a minute… no messages/status are shown and window return to same look as it began with. Power off the board and now stay away from that JL1 button… a number of boards were “bricked” IIRC when repeated attempts were made, thinking the first attempt had failed to flash the board. Start LB or some sender program and you should be able to connect and confirm that Grbl 1.1f is installed. If it is you’re done and you get on with configuring the Grbl settings to match your machine.

– David

Thanks men for continuing to stick with me. I will try this tomorrow. Thanks again!

1 Like

Hang in there… Sometimes it takes a while to get all of this to work together…

I had difficulties on my Linux box as I had to install an existing driver (module) for it to operate via usb.

Good luck

:smile_cat:

Yeehaw! I have got the laser installed and i think it is communicating with each other.
My problem now is: The laser module tries to “home” but it just sits there and vibrates like it’s trying to go backwards instead of forward. I got an error message in the Console window that says “ALARM:9
Homing fail. Could not find limit switch within search distance. Defined as 1.5* max_travel on search and 5* pulloff on locate phases.”
Please, what should I do?
Oh, the laser is in the back left position and i set the home as front left.