Connecting and communicating Laser JL3 with Lightburn

If there was already a ROM.bin I’d assume that to be the GRBL firmware. Else rename the one as per the video.

If you are concerned, I would contact Wainlux and ask for the firmware from them directly. It doesn’t appear easily found in my searching, similar to what this other user noted: JL1 (JL3) GRBL firmware avialable - #4 by LsrSal

I got as far as the “start upgrade” window. I pushed the button on the laser and powered it on. I clicked the start upgrade. The green bar went across and stopped at the end. Nothing. I waithed 15 minutes and clicked the start upgrade button again. Another small window opened that says “No device found”. What should i do next?
Oh, the “file” i opened to upgrade was UP_BLE_v1.3

It’s what mine did and that you can longer connect with their software means it probably upgraded…

You should be able to talk to it with Lightburn.


Do I just X out of upgrade and try it?

The upgrade process I did just did it… I had to just kill it. Then their software would not connect, but Lightburn would…

My machine is JL1, I think… but I bet it’s the same controller/firmware.


I think this is the same controller as the JL1 board that we dealt with in the $79 Cenoz laser engraver thread. That “upgrade.exe” program file is very minimalistic and gives no indication that it completed successfully… but if it also gives no indications of anything wrong, then it should be good. The progress bar usually appears to go to about 80% or so and then it completes so quickly as to not be seen/noticed and the window returns to its starting state. You’ll need to “trust” it at this point and move on to testing it to confirm.

Basically you’re hooking the Windows computer (with the “upgrade.exe” and “ROM.bin” files) to the un-powered controller board with USB cable per normal… and then you HOLD the JL1 button (between the USB and power connectors on the controller) while powering on the laser machine. That puts the board in “upload mode”. Run the “upgrade.exe” and a simple pop-up window with one button and progress bar… click the “Start Upgrading” button. Green progress bar starts and completes in less than a minute… no messages/status are shown and window return to same look as it began with. Power off the board and now stay away from that JL1 button… a number of boards were “bricked” IIRC when repeated attempts were made, thinking the first attempt had failed to flash the board. Start LB or some sender program and you should be able to connect and confirm that Grbl 1.1f is installed. If it is you’re done and you get on with configuring the Grbl settings to match your machine.

– David

Thanks men for continuing to stick with me. I will try this tomorrow. Thanks again!

1 Like

Hang in there… Sometimes it takes a while to get all of this to work together…

I had difficulties on my Linux box as I had to install an existing driver (module) for it to operate via usb.

Good luck


Yeehaw! I have got the laser installed and i think it is communicating with each other.
My problem now is: The laser module tries to “home” but it just sits there and vibrates like it’s trying to go backwards instead of forward. I got an error message in the Console window that says “ALARM:9
Homing fail. Could not find limit switch within search distance. Defined as 1.5* max_travel on search and 5* pulloff on locate phases.”
Please, what should I do?
Oh, the laser is in the back left position and i set the home as front left.

A few questions:

  1. Does your machine attempt to home immediately upon powering on?
  2. Did your machine previously home properly with the native software?
  3. If yes to either of the 2 above, to what corner did it originally home?
  4. How many stepper motors are used for the Y-axis?
  5. Can you physically see limit switches that would be activated with the laser module at left and back position? Or left and front postion?

To try and answer your questions, I have never got it to communicate with the lightburn until just now. The laser has always been in the back left corner since I assembled it.
I dont know what stepper motors or limit switches are.
Thank you for answering.
When I power it on, it starts vibrating like it may be trying to move. It vibrates about 15 seconds, stops, and then i get the error message.if

Did you ever connect the laser with the native software provided by Wainlux?

These are the motors that drive the motion of the laser. They’ll look like this:

These are typically electromechanical switches that are meant to detect proximity to an object.

They come in all sorts of shapes but could look like this:

These get activated when the laser head moves to the home position. However, not all lasers come with these.

Please review the previous questions to see if you can provide more information based on this.

Try this, with the laser off, slowly move the laser head to the center of the bed, then turn on. Does the laser attempt to move to any corner?

I moved the laser to the center and turned it on. It moved to the back left corner and started vibrating again like it is trying to go further it stops vibrating after about 15 seconds. There are 2 small black boxes with red buttons in the wiring but im not sure what they are.
I guess I have 2 stepper motors.
How can i paste a photo so you can see what im talking about?

Get a photo or screen shot - drag and drop it on the reply window… Same with some other file types.


Hi Jack, I figured out the small black boxes with the red buttons (see prior post) were limit switches.
When i turn the laser on it goes to the back left corner, hits the switches and comes back to front left corner👍.
I sent you a ScreenShot of my laptop. Now I,m getting an Alarm 2
Any ideas?

Figure out how to cut and paste or screen copy. A photo of the screen is sometimes un readable.

When you boot it, and it’s completed it’s homing, see what you get with the ‘get position’ in the move window.

Mine did the opposite, homed to the front/right and then moved to the rear/left…

I ended up running LsrSal firmware… It’s not a release version… Might want to stick with what you have…


This is usually handy for those that aren’t sure how:

Roger - Error 2 means the machine is being commanded to move outside of the area it can possibly move. Usually this is due to a misconfigured Origin point for your laser. If you go to ‘Edit > Device Settings’ what is selected here:

If it looks as it does in the image above, try selecting the circle directly above it (the top left circle) this will set your origin point to be where your laser goes to home (which should be the case)

The screenshot is a lightburn error message, it says: "ALARM: 2
G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right click the ‘Devices’ button to reset the connection). On or near the line 2:

Does this make sense to you?

Colin, that’s something ive been confused about. I dont know what my working size is. How would I know?