Connection issues, port failed to open

I’ve searched through the similar posts on here and cannot seem to find anyone having quite the same experience as I am.

I have a Kentoktool 400pro upgraded with their 10W laser
Installed LaserGRBL and drivers

I have had this laser since December and am by no means an expert with it but I have been getting by, but things are not working as they have been for the last few months.

Lightburn doesn’t find my laser, it gets to 25% in the search and then freezes and is force closed by windows. When I add the printer manually I am not sure which GRBL option to pick for my machine and that might be part of my further issues.

Once I manually created the machine I was able to connect and run programs. I did have the hard limit reached issue that would lock everything up but this was always remedied by flicking the power switch off then on. ( I also changed the position the laser returns to (1,1) instead of (0,0) which has stopped that issue for the most part in general.)

Now however, seemingly out of the blue when I try to connect the laser all I am getting is the port failed to open error and no amount of off and on gets it to re-link. The only solution I have at the moment is to restart my computer with the laser on and then open lightburn again and it will connect. (Just restarting lightburn does not work) a few times after waiting for the connection for long enough i will get this error info.


entry 0x400806a8

[MSG:Using machine:MKS DLC32]

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

Any help would be greatly appreciated!

Pick the straight “GRBL” option.

Does your machine have homing switches? If so, does homing work correctly?

You may need to increase the homing pull-off to create more buffer from the switches. This is done by adjusting $27 in Edit->Machine Settings.

This doesn’t look like an error. Just a Welcome message.

Can you take a screenshot of Edit->Device Settings?

Can you also run these commands in Console and return the output?


Yes, homing works fine before the hard limit occurs.

This seems like the correct solution I didn’t know this could be changed.

It never give any of this when it works properly it just homes and is ready to go.

I got no output when I put these in. I turned on lightburn before i turned my laser on so it didnt connect though. I will restart my computer and get it connected and see what it outputs

this is what normally comes up when it connect properly




Thank you for the quick response, I will try to adjust the home pull off and see if that corrects the hard limit issues.

If you turn on LightBurn before the laser what often happens is that the requisite Port value is not selected in Laser window. Selecting the port will attempt to connect.

You can force a reconnect by right-clicking the Devices button in Laser window as well.

Yes, which would normally be how i reconnect or power cycle. but that is no longer working and i don’t know what changed.
I just recconected with the device button and this is what im getting again
none of the controls work and it just says busy.

In that case I’d suggest 2 things:

  1. Try toggling DTR Signal in Device Settings
  2. If that doesn’t improve things then this may be a communication issue. The garbled characters are indicative of this.
    2a. Try a different USB cable and port on your computer. If you are using a USB hub remove it from the equation.
    2b. This may also be a sign of a corrupted firmware flash. Try reflashing the firmware to see if this resolves the issue
    2c. This could also be an issue on the computer side. Try a different computer if it’s available to you.
    2d. This could also be caused by a hardware failure in the controller. If all other issues are ruled out then this could be the reason.

Question, has anything else changed in the environment or setup? Have you added any new hardware or moved location?

So I toggled the DTR signal and initially it didn’t resolve the issue but then I forced the connection through devices and now it seems to connect on its own any time i turn the laser on and off! I will still look into the firmware to see if there are any updates but i can live with this.

Nothing has changed in the setup since i first hooked it up. I never even hooked it up with the original usb cable and went directly for a higher quality one thats a little longer to suit my set up so i wouldnt imagine thats an issue, plus when i restarted and hooked the printer up it would run through jobs perfectly unless i made it hit a hard limit but usually i just home it right after job to avoid this and dont send it towards the edges.

Well that’s promising. Odd that behavior would change over time however so not entirely comforting.

Anyway, glad you’re up and running for the time being.

seems to be working repeatably now. I am however still getting the hard limit error when ever i get to a 0 axis and the homing switches click. I tried the homing pull off but that does not seem to change my zero position in relation to where the switches enact which i think is causing the issue because they are being hit when not in a homing command

Try setting quite a large value for the pull-off. Do you see the actual distance from the switches post homing increase when you do this? What are the coordinates post homing?

i set it to 50mm, It definitely increases the amount it pulls off, but when i then send the laser back to the origin it signals the hard limit when the homing switches click. If i could offset the origin based on the home position i think it would be fine

when i send the laser to the max range where there are not switches it doesnt have an issue

How are you doing this?

Can you run these commands in Console and return the output?


Either with the click to position or the go to origin button.

originally the go to origin after job was toggled on so every time a job completed it would go to the origin and it would fault out. after I increased that to (1,1) or just dont have it move after the job I dont really see issues during use. This is only an issue because i plan on building a base to secure the laser to that will allow me to create a raised corner at the origin to line up my pieces and to do this i was planning on having the laser cut that corner so its dead nuts.

What coordinate are you going to with this?

Have you previously used the “Set Origin” button to set the origin? This is an arbitrary location.

Are you talking about the “Return to finish position” in Device Settings? This is also an arbitrary location. Just set the position where you’d like the laser to go.

It looks like your laser is configured to set coordinate to 1,1 after homing. Not sure why the maker set it this way but it may be complicating ithings. You could potentially create a custom firmware build that changes things.

not defining coordinates. using the icon that looks like the GPS pin and selecting in the grid where to send the laser. If I click on the x or y axis to send it there it clicks the homing switches and faults.

I did not know i could set the origin