Connection Loss

I’ve lost connection with my Ortur. My MacBook Pro “sees” it in the USB chain, but won’t recognize it via the console. I’ve tried switching USB cables, upgrading software, downgrading software, plugging in in various orders to no avail.

I’m at a total loss… any suggestions would be greatly appreciated.


Does the proper com port show in the Laser window? If not, see if you can select it in the pulldown. Try right-clicking on Devices button in Laser window to force a reconnect.

I deleted the previous profiles and created a new one. This time it came up with:

Port failed to open - already in use?
Waiting for connection…

Did you attempt the steps in my previous post? If so, how did it turn out? If not, can you try those?

Yes, I have chosen the proper port and then forced a reconnnect.

Port failed to connect - already in use?
Waiting for connection…

It’s odd, as the USB bus sees the Ortur.

Okay - I tried the only thing I hadn’t tried… rebooting the computer. Port open and working now…

Thank you for bearing with me. I feel mighty small now…


Hmm… I don’t like that it required a reboot but glad you’re up. And as you say, it was being detected on the USB bus.

1 Like

@berainlb Thank you that was helpful as I just selected the port to get it activated. How can I make it select the correct port every time?

If you always start LightBurn after the laser is connected and powered on than LightBurn will default to last used laser. It’s only when LightBurn is started and does not detect a connected laser that it will search for the next available COM port.