Connection Lost with Smoothieware

Hello!

I get random “Connection Lost” error during engraving, and after several days of the tests, I assume it is Lightburn issue. So will be glad for any help.

I have Smoothieware CNC on MKS Sbase with Endurance Laser on cheap chineese frame (I used GRBL and Arduino based controller before). It works under old laptop control on latest Windows 10.

So during engraving I got Connection Lost error. I thought it may be because of compressor for air assist or power relay work, but I excluded this, it appear without any connection to equipment actions. Also, the board stay active, it don’t halt or reboot, it saves previous laser head position and can be controlled after this error without any issues.
Yesterday I did more tests and now I am sure, that something wrong with LB, because:
I did successful 3 hours engraving from SD card, without connection to the PC (I have LCD to run commands)
I did successful 3 hours engraving from GCODE file (the same gcode) in LB, with USB connection
and today I run it again, directly from LB, and got an error after 12 minutes. Sometimes I get the error after 3 minutes and sometimes after 45 minutes (or no error at all but the chance is near 25% for this, as I had 4 failed jobs per 1 successful).

Right now I am waiting for another test, all the same, just to be sure, that it will repeat again.

So I will be glad for any ideas.



And as expected:
image_2021-02-16_150023

I found “Enable Debug Log” option in LB. How it works? Where I can check the debug logs? There may be some answers.

Hallo, es hört sich jetzt vielleicht seltsam an aber ich hatte 2 Wochen lang das gleiche Problem.
Sporadisch hatte ich Verbindungsabbrüche. Konnte dann nicht mehr auf den Kontroller vom Laser zugreifen. Erst wenn ich die USB-Verbindung trennte und wieder herstellte kam eine neue Verbindung zustande. Das passierte auch mit anderen Programmen. Manchmal nach 5 Minuten und ein anderes mal nach über eine Stunde. Es hatte Wochen vorher ohne Probleme gelaufen. Ich fing an alles mögliche abzuschirmen, alles ohne Erfolg. Danach wurden der reihe nach alle Elektrogeräte im Zimmer vom Netz getrennt. Wieder ohne Erfolg.
Durch einen Zufall bemerkte ich dann das diese Störung von einem Kühlschrank im Nebenraum verursacht wurde. Nachdem ich den Kühlschrank vom Netz getrennt habe sind die Probleme vorbei. Momentan trenne ich den Kühlschrank vom Netz wenn ich mit dem Laser arbeite. Bin noch auf der suche wie ich beides gleichzeitig benutzen kann.

Du solltest mal auf die suche gehen, vielleicht hast Du ja auch ein böses Gerät. :wink:

Well, LB reconnects automatically without any problems. I am curious, how this (connection error) can happen only during direct running from LB via USB, but no problems with gcode running from LB via USB.

Yeah, I have a fridge far away and compressor nearby, but I don’t see any connection, the problem appears not when these devices are on or off.

Anyway, thank you, I will keep eye on it during my next steps.

I did three more 3 hours tests:
USB + gcode - all good, it never failed this way, at least for now
USB + regular processing - all good (for a first time!)
USB + regular processing, 2nd run - connection lost after 40 minutes

PS: I got the logs this time:

21:55:59.330 D: R: 11 TB: 231 OK: 651153 RC: 651153
21:55:59.330 D: S: 11 TB: 242 LC: 651175 OK: 651153 RC: 651153
21:55:59.341 D: O: “G1X0.1S0.5\n”
21:55:59.341 D: I: “ok\nok\n”
21:55:59.342 D: R: 9 TB: 233 OK: 651154 RC: 651154
21:55:59.342 D: R: 11 TB: 222 OK: 651155 RC: 651155
21:55:59.342 D: S: 9 TB: 231 LC: 651176 OK: 651155 RC: 651155
21:55:59.342 D: S: 11 TB: 242 LC: 651177 OK: 651155 RC: 651155
21:55:59.352 D: O: “G1X0.1S0\nG1X0.1S0.5\n”
21:55:59.352 D: I: “ok\nok\n”
21:55:59.353 D: R: 9 TB: 233 OK: 651156 RC: 651156
21:55:59.353 D: R: 11 TB: 222 OK: 651157 RC: 651157
21:55:59.353 D: S: 9 TB: 231 LC: 651178 OK: 651157 RC: 651157
21:55:59.353 D: S: 11 TB: 242 LC: 651179 OK: 651157 RC: 651157
21:55:59.355 D: O: “G1X0.6S0\nG1X0.1S0.5\n”
21:55:59.357 D: I: “ok\nok\n”
21:55:59.357 D: I: “ok\n”
21:55:59.359 D: R: 9 TB: 233 OK: 651158 RC: 651158
21:55:59.359 D: R: 11 TB: 222 OK: 651159 RC: 651159
21:55:59.359 D: R: 9 TB: 213 OK: 651160 RC: 651160
21:55:59.359 D: S: 9 TB: 222 LC: 651180 OK: 651160 RC: 651160
21:55:59.359 D: S: 11 TB: 233 LC: 651181 OK: 651160 RC: 651160
21:55:59.359 D: S: 9 TB: 242 LC: 651182 OK: 651160 RC: 651160
21:55:59.363 D: Serial write error: “The I/O operation has been aborted because of either a thread exit or an application request.”
21:56:03.330 D: O: “G1X0.2S0\nG1X0.1S0.5\nG1X0.3S0\n”
21:56:03.331 D: 31023874 bytes in 2406.89 seconds, 12889.6 avg bytes per second
21:56:03.331 D: 651182 lines @ 270.549 avg lines per second
21:56:03.357 D: “Disconnecting…” busy: false state: 0
21:56:03.414 D: – candidate port PID 24597 VID 7504
21:56:03.414 D: mfr: “Microsoft”
21:56:03.414 D: prod: “USB Serial Device”
21:56:03.414 D: name: “COM7”
21:56:03.414 D: Found port: PID 24597 VID 7504
21:56:03.414 D: Manufacturer: “Microsoft”
21:56:03.414 D: Product: “USB Serial Device”
21:56:03.414 D: Name: “COM7”
21:56:03.414 D: HWFlow: true
21:56:03.417 D: Port open succeeded
21:56:03.419 D: I: “Smoothie\r\nok\r\n”
21:56:03.420 D: “Attempting to connect” busy: false state: 1
21:56:03.420 D: “Connecting…” busy: false state: 1
21:56:03.435 D: O: “G0\n”
21:56:03.435 D: I: “ok\n”
21:56:03.686 D: “Connecting…” busy: false state: 1
21:56:19.576 D: Clipboard data present:
21:56:19.576 D: (“application/x-qt-image”)
22:01:39.197 D: Clipboard data present:
22:01:39.198 D: (“application/x-qt-windows-mime;value=“Shell IDList Array””, “application/x-qt-windows-mime;value=“DataObjectAttributes””, “application/x-qt-windows-mime;value=“DataObjectAttributesRequiringElevation””, “application/x-qt-windows-mime;value=“Shell Object Offsets””, “application/x-qt-windows-mime;value=“Preferred DropEffect””, “application/x-qt-windows-mime;value=“AsyncFlag””, “text/uri-list”, “application/x-qt-windows-mime;value=“FileName””, “application/x-qt-windows-mime;value=“FileContents””, “application/x-qt-windows-mime;value=“FileNameW””, “application/x-qt-windows-mime;value=“FileGroupDescriptorW””)
22:01:39.215 D: Align output unchecked
22:01:39.223 D: EV: 1018 took 20 uS
22:01:39.224 D: EV: 1013 took 763 uS
22:01:39.225 D: EV: 1018 took 18 uS
22:01:39.227 D: EV: 1009 took 2999 uS

PS2: another attempt with direct engraving, another fail, the same error in 2 hours.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.