Continual Crashes When Connecting to Laser Via USB

Hi all! Hoping you can help this Lightburn newbie out. I’m running 1.4.00 on my Windows 10 Microsoft Surface Go, controlling my Gweikecloud Pro.

Unfortunately Lightburn has been super temperamental when it comes to connecting the cutter via USB, and Ethernet is not an option with this cutter.

Lightburn will freeze if I start it after I have turned the cutter on. Lightburn will not freeze about 30% of the time if I turn Lightburn on first, turn on the cutter, and then select the COM5 port in the device dropdown. It is now refusing to connect at all and instead crashing when I try to select COM5. This happens whether the camera USB is connected or not.

If I succeed in getting it connected, Lightburn will occasionally moodily let me one operation and then seize up if I try to press any buttons upon completion, and not respond. I am unable to run 2 operations in a row (except for about 2 or 3 out of 30 operations so far).

I have tried switching USB cables, reinstalling Lightburn, reinstalling drivers, and letting the Gweike folks root into the machine. I’m at my wit’s end, here - would appreciate some guidance on what else I can try. Is it a hardware issue on my tablet end? Are there settings in Lightburn I should fuss with?

Thanks in advance.

Check out @BillieRuben post on your machine… Maybe she will drop by and be of assistance…

Ensure your usb isn’t going to sleep, then you would loose the connection…

Does the red ring light up?


The red ring doesn’t come up. Unfortunately not related to anything in that post. I’m thinking it may be a memory issue? Going to drag my PC up from the basement tomorrow to test.

I only brought up the red ring, because that machine has no console…

Do you get any kind of error message?

Does the laser window go from Ready to Disconnected?

I tried usb on my Ruida for about a week and pitched it for a network connection. I don’t think the Ruida is very smart when it come to it’s communications… too bad you can use Ethernet…

I don’t have one of these to try it, but it seems odd that that has been disabled on the Gweike lasers… The OMTech Polar will allow an Ethernet connection, as far as I know.

With a Ruida, I use Send to get the file to the Ruida, instead of Start… which do you use?

Reloading all these parts are usually not the best way to handle these kinds of issues… If it’s working and fails midstream, I’d be looking at the os or some kind of timeout situation…

Unfortunately Windows os has created a generation of reinstall, reboot…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Hello! I just wanted to check is it the whole of LightBurn freezing, or just the camera feed? I’ve had the camera drop out plenty (basically every job. :frowning: boo-USB) but haven’t yet experiences the software crash on either my mac or windows.
Is this happening when trying to run the same job? Or no matter what? Does it also crash when you try to preview the job?