Crash when camera loads

Hello, I’m installing a USB camera to control my laser, in Windows in the camera application I can see the image perfectly, but when I open Lightburn and try to view the camera, the program crashes and clouse.

I also performed tests trying to run the program as administrator and also reset to default layout.

I also tried to disable the notebook’s onboard camera, but the same problem occurs.

I recorded a short video showing the problem.

I’m using Windows 11 Pro 22h2
Lightburn 1.4.00

Computer is an Acer Nitro 5 I5, 32gb of ran, vga nvidia 1650

Camera specs:
170 Degree
Sensor: 1/2.9" CMOS GC4053
Pixel:4MP, 4 megapixels, 2560(H)x1440 (V) pixels
Maximum resolution: 2560x1440
Output image format: MJPEG
USB protocol: USB2.0 HS/FS
Support free drive protocol: USB Video Class (UVC)1.1
Audio: With microphone
AEC Auto Control Exposure: Support
Auto white balance AEB: Support
frame rate:
2560(H)x1440(V) pixels MJPEG 30fps
1920(H)x1080(V) pixels MJPEG 30fps
1280(H)x 720(V) pixels MJPEG 30fps YUV2 30fps
640(H)x480(V) pixels MJPEG 30fps YUV2 30fps
Adjustable parameters: brightness, contrast, color saturation, gamma, WB
Night Mink: no
Minimum illumination: 0.1 (F1.2,AGC ON)
View Angle: Wide Angle
Working voltage: DC 5V
Working current: 150mA
Working temperature: -10 ~ 60 ℃

I am at your complete disposal if you need to carry out tests or send more information.

Hi Gabriel - please start by reviewing the guidance here, and let us know how that goes: Getting your camera to work in the hellscape of Windows

Hi, thanks for replying.

I checked anti-virus software and even disabled it.

I checked Windows security settings including Lightburn appears in the list for having accessed the camera recently.

I also tried running the program in compatibility mode with Windows 8, and then with w8 and ADM,

Unfortunately all the results were the same as in the video.

Are there any other tests or adjustments I can perform?

Today I had the opportunity to test another computer, with Windows 10 x64, with a trial version of the test program, the behavior was exactly the same when I tried to access the camera, I also performed the tests requested above on that other machine, but the result it was the same.

I was having trouble getting Lightburn to display the picture from my new “webcam”. The camera worked outside of LB and LB would recognize the camera but nothing else–No picture, no setup options. I looked through the settings and found that changing the setting in the lower left from “Custom Camera System” to “Default Capture System” did the trick. You do have to end LB and restart but when I did, LB showed the picture, and I was able to start the camera setup routine.

I’m running Windows 11 Pro on a mini PC. The picture below was after restarting LB.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.