Crash with .ai files

Using the website
There are some issues with the generated files. If I save as a .dxf or an .ai they do not add the file extension, I have to do that after downloading. That’s not an issue really.
When choosing .ai, the download completes and I rename the file to a name with the .ai extension. No problem with that. When opening with Lightburn, the program crashes. See image. The same file will open ok with RDWorks though. If I export from RDWorks as an .ai then LB will open the file without issue. Not allowed to upload an .ai file here but heres the crash.
dxf files open fine but need to be joined


Just as another data point, I did an export as an .ai file type from within LB .9.02 and saved. When I did an import via Lightburn to open the file, it worked fine.

I do agree with you that it would be nice for LB to automatically do like most programs and append the end of the file with the chosen file type’s extension (e.g. add .svg if I choose .svg in the drop down or .ai if I choose .ai, etc.).

LightBurn should not crash, so thank you for this report. I can duplicate the issue with file generated from “” site. I will create a bug report.

This is not required in LightBurn as the extension for the export file type you choose is appended for you. This is an issue with the files generated from the “” site, not LightBurn.

Happy to help!

The reason the AI version doesn’t work with LightBurn is that it’s not a real AI file, but an embedded postscript file. LightBurn is supposed to recognize these and warn, but the header tag in these files was a little different. I’ve adjusted the warning to catch these too.


The DXF, PDF, and SVG versions all work properly.

1 Like

DXF comes in all apart and needs to be joined… all little unattached lines. Easy enough to do but just an fyi
Just tried an svg and its all unattached as well

How do you have your ‘DXF Importing Settings’ set?


I had the auto close setting on 0.000 … default since I never changed them. I changed it to 0.500 as in your example but it didn’t work on the import. Also tried both mm and in

The setting in the picture provided was a quick test I did so you may need to adjust for your setup.

That being said, the files generated from that site have unusual lines created in corners. Look to me like they are setup more for tool path than laser, have double lines and would need some editing before being ready for cutting.


I have not dug into all the settings provided from the file generation site, looks like there is a ton of tuning tools for each design. I’d also look there to see if there are additional controls for better “laser” file creation.

And here are some bits left over after the ‘Auto-close tolerance’ on import.


That tool creates those tiny arc overlaps for some reason that I’ve never understood. They’re in all versions of the file, and all versions are also disjointed. You can close them after importing by using the auto-join tool (Alt-J or Edit > Auto-join selected shapes). Don’t set the close tolerance too high for DXFs - I usually set it to 0.1mm or 0.05mm.

The tiny overlaps are burn correction. If you set that to 0.0 the lines will line up perfectly. If you give it a value, that is how they correct for beam size
“burn correction in mm (bigger values for tighter fit)”
Even set to 0.0 with no squiggly lines they are not joined on import into LB.

Thank you for the “burn correction” info. I set to zero and have the close tolerance set to 0.05. Worked perfect and no overlapped paths in corners.

You’re welcome. I still have to use auto join, did you?

Ahh - they messed up the offsets then. If you use the offset tool in LightBurn it does the same thing, but then those overlaps get trimmed off the end result. Setting kerf on the cut in LightBurn would give you the same result without all the weird bow-ties.

To tighten up a joint would you use a negative kerf value?

No, did not use ‘Auto-join Shapes’. Was not required.

Outward kerf is positive in LightBurn - it will actually show “outward” or “inward” when you change the numbers.

Copy that thanks…

Today I was testing out the kerf offset in LB. I used a couple of tabs from a file for testing with 0 burn correction on their file so that their lines met perfectly and they were all joined up.
I started out with a positive decimal value in LB (outward) and progressively moved up in value until I reached the max setting of 5.000. There is no change in the fit of the tabs for any of the settings. This is with 3mm birch ply. The pieces drop cleanly and hardly any charring. Wipe a paper towel on the edge and it does not leave a mark on the paper., well maybe a trace but not much.
Am I doing something wrong?