Cut might be out of bounds - continue anyway?

on version 0.8.06 I get this pretty annoying nag every time I cut:

“Cut might be out of bounds - continue anyway?”

I use job origin, I have no home or limit switched, I don’t use home, and I cut from the center of my 850x410 cutting area. I can cut a 10mmx10mm square and I still get this popup. How can I make it go away permanently?

Machine: OpenGuilds ACRO - GRBL 1.1

Also for the support team: I don’t think I have an “offset applied” - unless it’s something that automatically happens. Since I don’t know what it is, it’s probably turned off.

Because you have no home or limit switch your machine will never know whether it is safe to cut or not because it doesn’t know where it is starting from.
I suspect the easiest way to make this go away permanently would be to add some limit switches,
Which machine/controller do you have?

I don’t think the answer to a software problem is to change the hardware on my machine. I never have any problem with going out of bounds. I also never got this nag before upgrading. The software should have a way to turn it off I think, for machines set up like mine, which is not uncommon.

I run “from current position” at the advice of LightBurn from last year and it’s been great - stopped all of the crashing. My work area is very large ad I always run a frame before the job

There will be many ways to solve this problem, I’m sure the Lightburn folks could change lightburn to make the warning optional. That was merely the first suggestion to something you could do to your own machine rather than waiting for other people.

It may still help to know which controller/machine you’re running, there may be an option in the settings that other people know about.

Same issue with the Fabkit from Fabcreator. Not very disturbing but also not very logic. It didn’t appear in previous Lightburn version.

This is a new warning, and I’m going to add a switch to disable it for those with no limit switches installed.

When you click Start, LightBurn asks your controller where it is, and if running the job from there would take the machine beyond the size you’ve told LightBurn your machine is, it reports this - it generally saves people from lost work, but it’s annoying if you have a machine without homing enabled. The next release will have a fix.

2 Likes

This has been added, and will be in the next release.
image

5 Likes

As someone who has to click on that warning every time I run my machine, I’m super pumped about this. Thank you.

I swear this software and its development team is top notch. I don’t need this feature but its great to see how quickly they jump on things that solve problems!

1 Like

You mean the 1 developer, 1 half-time support monkey, and 1 quarter-time IT guy and bad ideas whisperer (aka biz dev)?

1 Like

That pretty much nails it :desktop_computer::monkey::man_technologist::bulb:

1 Like

Rob, please adjust bulb illumination intensity. Properly set, it should be a bit “dimmer”.

1 Like

:desktop_computer::monkey::man_technologist::poop:

That’s the best I can do, sorry…

2 Likes

I also get this warning every time I run a job. I do have limit switches and I’ve tried to home the machine to make the warning go away. I have not set the machine to home at startup… maybe that would fix it?

You should definitely try homing.

I used to get the same warning. I changed from user position to absolute coords and use job origin in the lower left. I also frame the job before I start. I don’t get the warning anymore. My machine does have limit switches.

Try running from Absolute Coordinates?

Same problem here, home every time, working in the middle of table, yet every time I get the code when I hit start.

Ray
Chinese Blue and white TS-4060
C3D board