Cutting direction does not match origin

Good day, I made my own cutting machine using mks dlc32 v2.1 and lasertree k40. I used Nema 23 stepper motor and TB6600 drivers.

My mechanical and electrical installations were completed without any problems. However, when it came to routing with Lightburn software, there was a problem that I could not overcome. I want to set the zero point of my machine as the upper right, but I could not match the directions of the direction keys on the TS35R with the movement keys on the Lightburn. However, I was able to map the arrow keys and gestures on both controllers to the starting point in the lower right position. At this point, I am sharing the grbl codes that helped me get positive results and the pictures showing what I want.


$$
$0=10
$1=100
$2=1
$3=5
$4=0
$5=1
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=1
$22=1
$23=5
$24=250.000
$25=1000.000
$26=250.000
$27=2.000
$28=1000.000
$30=1000.000
$31=0.000
$32=1
$38=1
$40=1
$100=80.000
$101=80.000
$102=80.000
$103=100.000
$104=100.000
$105=100.000
$110=6000.000
$111=6000.000
$112=6000.000
$113=1000.000
$114=1000.000
$115=1000.000
$120=225.000
$121=225.000
$122=225.000
$123=200.000
$124=200.000
$125=200.000
$130=1430.000
$131=1080.000
$132=50.000
$133=300.000
$134=300.000
$135=300.000
ok

How can I get this to the upper right zero point as I want? When I use Lightburn directly from the device’s settings menu, the y direction is reversed. I am waiting for your help and advice.

Let’s review to make sure you haven’t overlooked something.

Start by setting the correct Step/mm values in $100 & $101, plus conservative speeds and accelerations in 110, 111, 120, 121.

Then set the machine to move correctly in response to the jog controls. Because you are using GRBL, this will be controlled by the $3 bits. You must also set the STEP polarity and duration as needed.

Then set it to home correctly to the corner where you have installed the home switches, using the $23 bits. You must also set the various home speeds and switch polarities as needed.

Then set the correct maximum travel distances in $130 & $131.

With all that working correctly, set the LightBurn Device Origin to match the home position:

Note that the Device Origin must match the hardware: you cannot put the origin at a different location.

When you get to that point, the machine should home correctly and the jog controls move in the proper directions. If so, then you can set a workspace offset to tweak the coordinate values so LightBurn does what you expect.

@berainlb may have further advice when it’s behaving properly.

Be aware that this may not be something that can be overcome, at least not without changes to the touchscreen. The controls on the TS35 are defined independently of GRBL config. If available, you may need to rewrite the firmware for the TS35 to get the behavior that you want.

Having said that, I’d suggest first getting the laser and LightBurn working as you’d expect without regard to the touchscreen.

To what corner does your machine home currently? Is the firmware configured to zero origin at home position?

I cannot enter the $100-101 values correctly, because after making one cut and performing the axis calibrations, I will have the correct values, but I cannot make the cut because my coordinates do not match. I’m getting an out of limit error.

I will enter again by reducing the speeds and accelerations by 2/3.

Values $130-131 are correct. This is my clear working area.

The only place where the jog controls work correctly is the bottom right point I mentioned above. By trying all $2 and $3 masks, I could find that this was the only point that worked correctly on the touch panel and lightburn. When you say homing, the machine goes to the correct search directions (endstops are on the top right).

Should I set my zero point to the left front according to the device setting? So can homing be left on the top right?

1 Like

I don’t know how to rewrite the firmware of the ts35r. But I updated the dlc32 software with the newest version.

Okay, with the masks, I can make the controls in Lightburn work the way I want.

Currently, when the bottom right is selected, it goes to the top right. I had configured zero starting point but turned it off. Instead, I reset it myself by pressing the homing button every time I turn on the machine.

Hello, I don’t have time to help in any other way. But no wonder it is necessary to update the firmware version.
Check Github to see if there are reports identical to yours, I got the solution I was looking for here.

Another user-hostile machine!

I withdraw my suggestions. :frowning_face:

I would be happy if you share your thoughts with me. As a result, I’m not very familiar with this subject, I’ve just started. Every information given to me is very important for me to reach the result. I will try every suggestion. Experiences are valued as they are shared.

Unfortunately, all I know comes from using & configuring standard GRBL controllers, so I know nothing about the peculiarities of the machine you have: all my assumptions are wrong!

@berainlb has an encyclopedic knowledge of machine configurations, so his advice will be far more useful than mine.

I thought this was a K40, which is the low end co2… it appears to be a ssl (diode)?


Where exactly did you find the firmware… ? A link would be good :pray:

I have mine loaded with the laser version, they call it. However there is no screen… just says loading… seems to operate ok… just no screen. I did use the one for the screen I’m using… same as yours.


I have a shell script on my Linux box to upload a binary. Remove the .txt

firmware-upload-command.sh.txt (400 Bytes)

:smile_cat:

Run these commands in Console please and return the full text output:

$H
$$
$#
?

This is a diode laser. blue light
I installed it from Github, but I think I installed the wrong version. I will upload the latest version again. There are 5 or 6 topics opened on Github regarding this problem. I will try the solutions there. Isn’t 300000 baud wrong? Shouldn’t it be 115200 baud? In some grbl resources I found, they recommended 115200. Also, I don’t know what this baud is? :slight_smile:
I will try this link you sent bro.

I saw that there were people having the same problem on some issues. But no one mentioned a clear solution or I could not understand what was written due to the language difference. I think I will reach a conclusion thanks to you, brother.

Of course . I will when I get to the laser machine. I will share the outputs with you.

I found the solution on github site. They solved this problem in the latest version. But we can only determine the origin as the bottom left. Other corners do not work. Thank you everyone for your help and advice.

1 Like

Thanks for reply to us how you solve the problem. :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.