DIY 1390 - AWC708C - won't fire laser

I’m out of ideas on this one. I built a 1300x900 machine using Light Object parts. Everything tests correctly and works fine, except firing the laser. It fires using the test button on the power supply. But not from the control panel button. I can not make TTL voltage go LOW to pulse the laser.

I also have a Light Object Legend 1290 60 watt machine. It uses the same X7 controller. I backed up the software from this device and loaded it on the new X7. I have installed the new X7 in the Legend and everything works perfectly. I installed the X7 from the Legend ion the 1390 build and no laser.

The water flow sensor drives WP on the power supply to 0V, as expected.

I’ve spent time on the phone with Light Object support and they are also out of ideas.

All parameters in the controller are set correctly and have been checked, switched, returned to correct etc.

I’m connected to Lightburn via ethernet. No issues. Programs run correctly, the laser just doesn’t fire.

The only wiring difference on the Legend is the open door sensor, wired to IN 1. I have grounded IN 1 on the new build with no change.

I installed LaerCAD 7.98 and 8. something. Both connect to the X7, but no changes have affected the issue.

Thanks in advance for any suggestions.

1 Like

Forgive me, the Legend also has Z axis limit switches and outputs for wind.

Have you disabled the water protect input on the controller? I think it floats the safe way, so if it’s still enabled, then no fire.

That’s a really clean layout you’ve got!

1 Like

Thanks Ed. yes, I did. I also tried grounding WP on both laser outputs.

I can’t follow the wiring very well.

Where do you have L, IN and WP connected on the lps?

The IN should be the pwm, L is laser enable(active low), and WP (active low) should be held low if the controller is set to monitor the coolant.

Which of these isn’t right?



Unfortunately, that is how it’s wired. I wish it was a simple mistake.

PWM on the controller is wired to IN on lps. Red wire

TTL on controller is wired to L on lps. White wire.

GND on controller is wired to G on lps. Black wire and shield wire.

Making these fire and the determination of if it’s the controller or lps isn’t rocket science.

If these are wired right and the controller works it should work.

If it doesn’t work it’s a controller, wiring or lps issue.

It’s pretty simple… measure the control lines with a voltmeter…


1 Like

Agree 100% That’s why it’s so frustrating.

The controller, cables, power supply all work in the Legend. And everything meters correctly in the new build.

IN 1.8V
L 4.85V

When I press the test button on the LPS L goes to 0V.

Need to start looking at the lps…

Does the fire button work on the lps?

Might have to unplug the data cables to it to get it to lase…

I assume the mains voltage to the lps, input voltage, is ok and enabled.


OK, let’s do it on hard mode.

Print-screen the entire Vendor Settings list and show 'em here, so we can find the one thing nobody expected. :frowning_man:

The signals are there for it to lase, but it’s not. Points to the lps…

This looks like black goes to ground and the shield goes to ttl…?

Screenshot from 2023-03-09 14-04-24

Is not WP an input for both the lps and the Trocen?

You’ve measured it as 0V, but I’m curious.


Interesting…I connected the L to TTL of laser 2 output on the controller. Now the laser button fires the laser.

Running a job from Lightburn does not.

In my troubleshooting, I had moved the terminal plug to the laser 2 output. it didn’t change anything.
Maybe I should try that again.

Even more frustrating, I’m out of time today and I’m leaving town at 5AM. Will be back late Monday night.

Sounds like it’s configured to enable laser 2…?

Three steps forward and two steps back :face_with_spiral_eyes:

Good luck on your trip… we’ll be around …

Take care


1 Like

Last thing on my way out the door…

Plugged into laser 2 output. Nothing.

Wired GND and PWN into laser output 1, TTL into laser output 2:


The laser pulses from the button on the controller and runs from Lightburn. Not sure why. But I’ll take it.

Next week I’ll dig deeper and sort it out. Thanks, have a great weekend!

Can’t argue with success… I can say it’s probably a controller configuration issue…

Take care on your trip


1 Like

I’m stuck on a bus today. And it broke down. We’re waiting on a new bus…

So, what settings in software could create this odd situation? I’m going from memory, forgive me. I know only one laser was enabled. Even when the TTL output of laser 2 was controlling the laser.

I’m glad it works now, but it doesn’t reconcile that it works as normal in the Legend.

I recall that the Legend controller has firmware 1.2 something. While the DIY has 1.19 something. I’ll update this when I get back in the shop.

I selected parts that are used on the Legend for this new build specifically so I would have a working example to compare to and interchangeable software. Only the range settings should be different. 1200x900 on the Legend and 1300 x 900 on the DIY.


Paging through the AWC708C manual, there are some weird things (page 98-ish) about multiple laser heads, where Laser 2 can automatically continue if Laser 1 stops for whatever reason. I wonder if there’s a glitch where, even with multiple heads turned off, having the sub-options set causes what you’re seeing.

That would certainly violate the principle of least surprise, but it’d be worth reviewing the actual settings to verify they’re as neutral as you can make them.

1 Like

I’m back in the shop, catching up after being away. I reached out to Light Object and let them know I need resolution on this. I know it’s something fluky. I don’t have time to crack the terminal board open and start tracing voltages at each opto to sort it out.

I did notice the new X7 has older firmware. I’ll update that.

I need to move on to alignment, calibration, belt tension and so on.

I bet you’re right!

I backed up the software from the Legend and loaded it onto the new X7. The Legend is one head and works correctly, so you would think the settings would be correct. Yet, here we are.
I’ll be sure to post here when it is ultimately sorted.

Verily: Hell hath no fury like that of an unjustified assumption.

With firmware, the only valid assumption is that anything can happen!