Does ligghtburn work with Mac OS 10.13.1?

I keep changing usb cable and it will work with my Mac mini, OS 12.3.1, but not with my iMac (2010) OS 10.13.1? If the iMac is un supported fine. I just need to know.

It should work. You may need to install drivers.

I believe your laser uses CH340 usb-serial chip. Look here for installation instructions:
GitHub - adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver: CH340G CH34G CH34X Mac OS X driver

LightBurn supports MacOS 10.11 or later. What are you experiencing? What messages are being presented when you try to use LightBurn on your “10.13.1” Mac? You have not provided very much for us to use to offer any support of real value.

Please provide as much information as possible, using the following format:

I have an IMac (2010) running 10.13.6 with a new Nasum A5 Pro. This works great on my Mac Mini (2018 w/OS 12.3.1. The usb-serial choice doesn’t exist on the Imac so I assume the driver you suggest is required. I, however, being a Luddite cannot fathom the procedure outlined in your link. Is there a simpler method for installing this driver?

Download this file:

Install it by locating the file in Finder and double-clicking. Then reboot and retry connecting in LightBurn.

1 Like

Thank you so much for the simplified procedure. I and all the Luddites of the world salute you. Unfortunately it didn’t work. Any more ideas?

Did you reboot?

With the laser plugged in and turned on, can you take a screenshot of System Report->Hardware->USB?

Also, open a Terminal and run this command. Please return results.

ls /dev/*usb*

yes, I rebooted

here is pic of sys report usb. No idea how to 'open a terminal.

sorry, wrong pic.

Can you click on the other USB hub and take a screenshot?

You may also need to click on the BRCM2046 Hub to get down to every device.

What we’re trying to find is something that indicates that the laser device has been detected by the OS.

To open a terminal do CMD+space to open spotlight, then type “Terminal” without the quotation marks. Hit Return key when Terminal application is found.

Once open, copy and paste the command from above. Then copy paste the results back into a reply. You can close the terminal by typing “exit” without quotation marks in Terminal. Then CMD+Q to quit the app.

russell-webbs-macbook:~ uwasagadoga$ ls /dev/usb
/dev/cu.wchusbserialfd140 /dev/tty.wchusbserialfd140
russell-webbs-macbook:~ uwasagadoga$

russell-webbs-macbook:~ uwasagadoga$ ls /dev/usb
/dev/cu.wchusbserialfd140 /dev/tty.wchusbserialfd140
russell-webbs-macbook:~ uwasagadoga$

This is most likely your laser.

In LightBurn if “Find my laser” doesn’t return results, create one manually with this configuration:
Name of your choice
410x400 dimensions
Origin at Front Left
Disable auto-home

Make sure that the port is set to “cu.wchusbserialfd140” if it’s not auto selected.

Setup, test, and report back please.

Thanks, it finally seems to be working

1 Like