Double image burning

Anyone have any clue why this is happening, it cuts it fine, but does a second cut slightly off center of the original. I have it set to do 1 pass on fill.

Lightburn software, Laguna MX laser.


Much Mahalo.
Mike from the 808.

Might help if you drop the .lbrn2 file here for us to look at…

Check the mechanical first…


Double Print.lbrn2 (427.0 KB)

I cant figure this out.

Also, I should add, it does this AFTER it successfully burns the image. It runs a second time and this time is the offset. I dont know why it runs a second time, it is set to do only 1 pass.

As far as I can see there is nothing wrong with the artwork, seems to preview fine, albeit slow…

Might want to drop a line to support, I have no idea what to advise…


You might want to check the PWM settings.

How can this cause it to run two times?


Exactly, Im gonna try to create a square box, and fill it. If that does not print double, i will assume i did something wrong on the first file. If it does it has to be a setting in the software or machine thats doing it.

This is indeed very odd. My knee jerk reaction was perhaps you had an odd reflection inside your lens tube after the focus lens, but if the doubling happens AFTER the first pass well, that would be something entirely different. Please let us know how a test rectangle goes. Did this machine run flawlessly before this?

I looked at the file and it appears to run as expected via ‘preview’.


I didn’t read the entire problem. Looked like a skewed engrave.

Ok, this is what i found, when i use fill with cross hatch OFF, no issues. When i turn it on, it burns the image once in left to right direction, the second direction, up and down seems to be about 3 or 4 mm to the right side of the original image. This is whats causing the double image. I found the issue, but what the hell is causing it??

I have had exactly the same issue. Redraw the item and it ran ok. Sorry cannot be more help

Ok, here are some more results and tests.

When I cut the image with only one layer, No problem. The issue happens only when I cut a second layer. I tried the following.

Cross Hatch, multi layer at 45 and -45, and even the same layer, but run twice. The result on all of the above was a double image.

This leads me to think its a mechanical issue?

I would assume its not a laser issue as the point of the laser should not move, even if it were out of alignment. For example, if it were 3 degrees out of alignment to the left, no matter what direction i started from, it would still be 3 degrees to the left.

Could it be slop in the belts? Stepper issues? Freaking loose doohickey causing the thingamajig to slip!

Any suggestions would be appreciated, any links to video’s that may address the issue would be very appreciated!


Ohh, and I did reintroduce the image fresh, and re did all the layers new.

I remember back a ways, but it stated not to use scan angles that are not in 90 deg increments… on a Ruida


1 Like

i tried downloading the file to usb, and transferring from there to the laser, then printing directly from the laser. Same issue.
This time I did a box, first layer the line, notice how its square (4 90 degree sides). But the fill (same image as the lines) seems to skew to the right. I cant figure out why on line form, its perfectly straight, but ONLY while doing fill the issue arises.

The error is proportionate to the size of the overall drawing. If this is the case, it would lead me to believe it is some form of stepper or setting issue?

Does anyone have a Laguna MX, could i compare your stepper numbers?

IMHO - don’t mess with those :exploding_head:

Your system is digital up to the shafts of the steppers. You get a perfect rectangle in one instance, that tells you the hardware and configuration is probably ok for the positioning…

Do a small square with and without fill. Make the square and use ‘duplicate’ to copy, move it to a nearby location and change it’s layer/fill no fill…

Are you using flood fill?


Ok, next test. Made 3 inch square boxes, over the size of the bed. With one large line box around the whole thing. The lined large box, and 5 smaller lined boxes came out perfectly square. Bit when i filled the boxes, as you can see, the fill was askew. The fill became more askew as it progressed from the front to the rear of the machine. I ran this from my computer, and then via USB. I even tried loading Lightburn on a new computer. I checked the bed, and its level to the laser head on all 4 corners.

I assume that the fact that the line boxes were perfectly square, the gantry must be square. Only the FILL seems askew.

What the HELL is going on?

I still think it’s a PWM issues. Go to machine settings and see what the PWM rising is set to on the x and y axis.

Read the article I posted earlier.