Double Trouble - Selecting a single duplicate after ungrouping

I inadvertently created duplicates of the elements of a complex but repetitive design being used to make an embossing plate for leatherwork. I was working in line mode but when I was finished after hours of work, (so I thought) I switched to fill and Lighburn just laughed at me. I discovered that I had duplicated duplicates of all the elements and no fill for me! If there is a way to somehow select a duplicate layer and delete it, it wasn’t working. Once the element had been ungrouped, I could only select both copies simultaneously. I was able to painstakingly select duplicated segments with the edit nodes tool but there must be a better way??!!
Using V1.6

Have you tried edit> delete duplicates?

Menus - LightBurn Documentation (

Thwonk!! Sound of forehead hitting desk! I could have saved 2 hours or more this afternoon! Thank you!!!

Update: Delete Duplicate worked on the tests I tried but NOT on the original problem elements.I have an element exhibiting the problem> Software bug? I can select segments with the edit nodes tool and delete them one by one but not using the detect duplicates function.


1 Like

Delete Duplicate Not Working.lbrn2 (18.6 KB)
Here is a file that won’t fill and won’t delete!

Here is one of your problem areas. The shape is not closed here, but it won’t allow it to close either.

I looked further and you have lines on top of each other. I hade to break the nodes apart to prove it, but you can see here where I moved them apart there are multple lines in the same space. The easiest thing would probably be to redraw it rather than trying to manually find all the errors.

I’ll offer an alternative solution to recreating the shape:

  1. select shape
  2. Arrange->Break Apart
  3. Edit->Delete Duplicates
  4. Edit->Auto-join selected shapes
  5. Edit->Close Path
  6. Edit->Select open shapes, delete

That should leave you with relatively clean well-formed shape although I didn’t validate every node.

Try this one
Delete Duplicate Not Working_RRU.lbrn2 (17.4 KB)

That was much better than my idea to redraw. I tried break apart and auto join, but didn’t think about delete duplicates between steps. I love learning things.

Be advised, the duplicate to delete have to be an exact match (size and position) for the tool to work. If you Zoom all the way in and see multiple lines, it is not a duplicate.

Thanks everyone. I learned a lot and will save lots of time in the future. I am constantly amazed by the capabilities of Lightburn. I have been a Photoshop user since V.05 and always though of it as the most powerful graphics software, but after using Lightburn for a couple of years, Photoshop’s shortcomings are becoming obvious. Not talking about application, but the intuitive functionality and user responsiveness…and then there’s price!

Had I seen multiple lines when I zoomed in I would have selected one of the copies and deleted it.


Works like a champ!

1 Like

I did not mean that in disresprect. I put the note out there in case someone else was having dimilar issues and read this thread.

Absolutely none taken. I was looking for any double lines so I could select one of the paths and delete it. Again, it showed no duplicates even though the duplics are there

1 Like

Another VERY easy way is to use the [TAB] key. It will move the focus sequentially to each element in your project. Even better if LB included a window for “List of Elements” so we could easily choose them. The list should include;
Timestamp, Type, Width, Height, Layer (in color), Visible, etc.

Thanks. Good tip but it doesn’t work on the file I uploaded. There is an element and duplicate and it is impossible to select just one. You can edit with the edit node tool and pull on a node to show the dwo versions but still impossible to select just one and delete it. It must be a software bug.


I used the preview to see what was being burned. I see 4 passes, so I set it to one.

Using the node editor, I DO see multiple lines in the same place, but it’s still a single unit. Edit, Delete Duplicates finds no dups. But I do see several lines, joined at nodes.

How did you craft this part? Did you have Edit, Auto-Join Selected Shapes turned on? It appears to have multiple lines joined at at least two nodes.

I created the element, in Photoshop, then saved as an ai in Illustrator and imported. I thin decided to clean up the graphic and I recreated parts of it in Lightburn. There are 5 or 6 elements that are repeated in a Celtic knot design. I was in line mode, using the node editor. When I was done, I replicated all the elements one by one and replaced the originals with the new duplicate. When I though I was ready to burn, I switched to fill mode and it coughed up blood! I am creating an embossing plate in 3mm lucite, and this element is the deepest of the rest.



Just to add a little detail if left click select, it selects only one shape if drag select from right to left it selects the shapes and the duplicates.

Wrong! Doesn’t work on this element. Try it.