Endstops in Totem S 5.5

Someone can provide information or configuration to help install the endstop switches.
I have installed them in the lower left corner, the machine recognizes them but I have not managed to run them correctly.
I have installed the firmware 1.1h.
Please help.

GRBL configurations $22 - $27 are going to be the most relevant for you. Check those out.

What is the specific problem you are experiencing?

It doesn’t do homing, if I manually position it at the bottom left, with the switches pressed, it crashes and returns an error.

If you place the head in the middle of the work area and power it up what happens?

I want to know if the both machine axes are going to the home corner…?

Ensure your X & Y limits switches are not in the wrong axes.

It won’t home with the X axis limit plugged into the Y axis limit…

Cut/paste the output of the ‘console’ so we can see the boot and error message.


At Start:

Waiting for connection…
Grbl 1.2h [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
G-code locked out during alarm or jog state.
[MSG:Caution: Unlocked]
Target buffer size found

When push home button:

Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.
Grbl 1.2h [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]

Nothing happens, the laser does not move in any direction

Where did you get this version of GRBL? Is this what came with your laser?

I’m guessing what’s happening is that this is a 3-axis build of GRBL with homing configured for all 3 axes. In 3-axis homing the Z-axis would home first then followed by other 2 axes. Since you don’t have a 3rd axis with limit switch, it’s timing out.

You need to answer these questions that I first put to you.

When the head is in the center does the head move towards the home corner (front left)?

Are you X & Y limit switches plugged into the correct limit axis?

This means it failed to home.

Indicates that it was looking for the switch.

If you press one of the switches while the machine is idle, does it show up in the ‘console’ window?

Did you ensure the x limit is not plugged into the y limit?

On my grbl, the x, y, z axes connectors were actually z, y, x. It shouldn’t hurt the machine if you swap them and try it.

If the head goes the wrong direction change that axis home direction in the Machine settings. There is one for each axes.

A couple of the videos I watched, they changed it to $23 which reverses the X and Y axes homing direction. This would be known if you would have answered the initial questions…


The connectors are in the correct order.

The firmware has sent me from the Two Trees Department of Support via Wetransfer.

If this is not the right firmware, where can I get it?

Thanks for your help.

I’m not certain that the firmware is incorrect. But just speculating based on the error message and other symptoms. Did you confirm with Two Trees team that you needed this in order to do enable homing?

I do know that others with Two Trees were able to add limit switches. However, they were unable to save the configuration.

“berainlb” helped me a LOT to get my Totem S setup the way I wanted. I decided to mount the limit switches in the back right corner instead of the front left. I like having it home there and be out of the way when I’m positioning something on the bed, and return there when a print has completed. I designed and 3D printed mounts for the switches. The “X” switch uses the two existing screws that anchor the belt tensioner. I just had to use longer screws. The “Y” switch uses a T-nut in the inside slot of the right rail.

Berainlb presented me with the codes needed to get everything setup. Since the Totem S doesn’t store the codes and I haven’t found a way to have Lightburn execute them on startup, I decided to use the Macro0 button on the “Console” tab to store the codes, and I merely click that button each time I start Lightburn. I renamed the button “Home Setup”. You’ll need to experiment with the G10 “X” and “Y” values to get it fine tuned.

G10 L2 P1 X-299 Y-284

So far it’s worked without fail!

1 Like

Hi Trek2120, thanks for comment.

I also had the problem that it did not store the data in the EEPROM, until I loaded the firmware again, now if it stores the changes in the configuration well.

I like the design of the supports for the switches, it is a good idea, this afternoon I will design them.

Thank you very much for all the information, I’m sure it will help me.

I will continue commenting


Do you have a link to the frmware? Thanks…

Hello. I have the same problem as you.First time endstop work fine but $command are reset after restarting machine. I have installed a version of firmware sended by twotrees assistance. This is a grbl v 1.2… not work nothig. Reversed y axis, homing timeout and other stuff. Finally my machine not work. I d3cide to download the firmware from TT site. This save data but homing return error 9. Very very tired i have unplugged endstop.
Now where you download your FW an wich settings use?Your help are useful to any


I can maybe answer here: with the machine comes a stick containing lasergrbl. If you install and connect then you can use the tools there. One of wich is firmware install in which you can choose the firmware to use.

Would you be able to share with me firmware you upload that solved the issue?

The homing command stopped working once I uploaded the latest firmware downloaded from the. Two trees website.

A screenshot of the gbrl configuration would be very much appreciated. Also many parameters got screwed after the update.

Thank you in advance

Hi everyone :wave:
I have the same problem with my new totem s5.5. I mounted two endstops, one for axis, I tried to switching the connector, but nothing.
I using grbl version 1.1, downloaded from twotrees website

I usually read the forum here pretty often but haven’t been here in awhile. Just seeing these posts. Heres some stuff that helped me with my TwoTrees Totem S, instead of reposting everything heres a link to a discussion on reddit about the same thing, its just a grbl based board there is no special firmware for it

good morning. sorry, I’m French and I use a translator. I have a TWO TREES TTS55 10W.
I followed several tutorials, checked my connections, modified But lines 21, 22, 23. However, the homing does not work. the head hits at the end of its travel and the belts slip. do you have the complete list of lines to modify in GRBL?