Engraved words slanted but cutting is ok on Lionsforge Laser Cutting Machine

Feeling frustrated that I cannot engrave properly. I created the texts using lightburn or via SVG files which I created on Inkscape. However, when engraved, certain levels of wording will be slanted. Cutting is ok. Any help will be greatly appreciated.

Using a gcode laser cutting machine. I connect via usb cable to my lionforge laser cutting machine


this is my setting

We’ve all been there…
The most glaring thing for me is the engrave speed units.
100 mm/s is 6000mm/min.
This is likely responsible for all the frustration.
I suspect it will clear up if you keep it below 2000mm/min.

There was another user last year that had what looks like a similar issue with the same model of laser. The hardware is a bit unconventional. That user was using smoothie firmware, however, not GRBL.

In that case the lettering was wavy rather than slanted but could just be an issue in overall size.

The issue wasn’t resolved to satisfaction.

1 Like

@berainlb you have great memory!!

Indeed I’m also using a lionsforge laser but with upgraded controller! Thanks for your help the last time. The problem didn’t reoccur so we didn’t get to the bottom of things.

1 Like

@thehumblestudio have you tried speaking to keewee from lionsforge? The support is excellent!

And yes, speed is too high for lionsforge since it uses screw rods rather than belt. Try lowering it to like 15mm/s with lower power settings. In my own tests, even higher speed setting doesn’t seem to have any effect.

Nice to see you back on here. Your laser stuck out to me because it was very unconventional in its shape and use of the leadscrew. The artifact also seemed very similar to this one so triggered the memory.

1 Like

yeap. he trying to help as well. what we experience is that image text is ok but when text directly done on light burn or vector text then the problems comes in.

@Johann1314 i see your engraving speed is 1200mm/min and when converted to mm/s is 20mm/s ?
am i right or my calculation is wrong? :smiley:

Yes! the issues seemed really similar and both point to the communication between LB and the laser being the problem…

you are right. I just decided to try from that speed onwards since i already had the settings that worked on another test piece.

when i was on the original Gcode controller, i played with Gcode directly and noticed a few peculiarities with the controller. like for example if Gcode specifies a negative X location, the laser will try to move there (and fail), but the next X movement to a positive X value will behave as if the laser had been able to move to the negative X position. The net effect is an offset of all the subsequent movement to the right by the same negative x value.

Another thing I noticed was that I needed to break long cuts/engraving (those taking like 40mins and more) into several smaller cuts sent separately. If not there’s a risk of skipped steps happening late into the cut for both fill and lines.

While neither of those seemed to be the cause of your problem, it hints to me that the controller has some limitations, so it’s best to try to slow down the speed if possible.

I hadn’t come to the same conclusion based on the symptoms. Communication issues typically manifest differently. But this could be checked by using LightBurn g-code and using something else to send to the laser.

1 Like

alrighty…shall take note of the speed…cause previously keewee told me to be 130mm/s