Error 9 after installing y axis roller

set up Y axis roller. Done test burn. went to do first real burn, laser head went left until hit frame and started bouncing. i hit stop. I then got a " G code locked out during alarm or jog state, On or near line 0:
Im very new to this . Any help be great. Thanks

Same! Played with the starting origin of the laser head and took it off auto I believe. Now I’m having an issue with the laser making multiple passes on cylindrical objects. I stopped messing with mine shortly after because I couldn’t locate any support on this issue. Then I started seeing select post about what we experienced potentially frying the motherboard!? I got discouraged and didn’t touch mine for months after. Now my trail has expired and before I spend the $$$ on software I don’t know about I’d really like a good walkthrough. Does anyone have any recommendations for links?

Edit* I also grounded the frame to fix the homing issue and that fixed the issue of stopping the job when I was testing on flat surfaces as well.

Error 9 in grblease is a homing error. If your machine homes properly and you remove the Y axis to put it on your roller, how will it home now? Probably because you hit the panic button…

Generally, on the Chinese lasers we get it pretty well setup, then plug in the rotary last. It won’t have to re-home.

Your configuration for it will be quite different than the Y axis. You might try looking at other threads for your issue. Looks like you found the grounding issue.


If you send your trial ID to we can extend it for you.

Problem solved [ $RST=*] I typed this command in my consol window. Hope this helps some other newby like me.

After some conversations with Gil (from Ortur) it turns out that their firmware people added some “features” to one of the settings in the machine.

Short version, $22=0 to turn off homing, $22=43 to turn it back on (ONLY for the Ortur).

Longer version: In GRBL, the homing enable setting ($22) is a boolean, meaning it can be set to 0 (off) or 1 (on). They turned it into a bit-field, meaning it now has other features, so “on” is now 43.

bit0 : 1   (homing enabled)
bit1 : 2   (??)
bit3 : 8   (??)
bit5 : 32  (??)

Why they did this is beyond me. I think they were trying to get clever and not have to add another setting, forgetting that this will break every GUI that exists and knows that this setting is only supposed to allow 0 and 1.

They are apparently going to fix this in an upcoming firmware update.

Using $RST=* will also work, because it resets all settings back to their factory defaults, but using the $22=43 setting means you won’t lose any changes you made to things like acceleration, speed, etc.

1 Like