Error Code 20 - please help

Hi, I keep getting error code 20 everytime I try to start the project Please help.

Here is what I see…

Starting stream

error:20

Unsupported or invalid g-code command found in block.

On or near line 2:

error:20

Unsupported or invalid g-code command found in block.

On or near line 4:

error:20

Unsupported or invalid g-code command found in block.

On or near line 5:

Stream completed in 0:00

ok

ok

ok

Can you save the Gcode in Laser window using a .txt extension and then upload that file here for review?

What laser cutter are you running (model name) and what process did you follow to set it up?

1 Like

I have the Ortur Laser Master 2. I had it working fine until I got code 20.

Thanks! And has anything changed in your set up? Were you able to save that GCode for us to take a look at?

A post was split to a new topic: Atomstack S10 : Error 20 unexpected Gcode

Here is the G-Code for the file. Nothing has changed, still same error.

Avery Cup.txt (521.3 KB)

It looks like you have Rotary Mode enabled and set to the ‘A’ axis. Try toggling Rotary Mode off. You can go to ‘Laser Tools’ > ‘Rotary Setup’ to find the switch, if you don’t have it enabled in your Laser window. If you are intending to use a rotary, it should be set to the ‘Y’ axis- that can also be controlled in the ‘Rotary Setup’ window.

I fixed the axis and it is on Y axis, however when I sent it to burn, it is burning something other than what is on my screen. It is not the image I have in Lightburn. The image is stretched very wide with many lines.

Below is the G-Code

Avery Cup 2.txt (3.0 KB)

Can you upload the .lbrn file that was used to generate the gcode?

Darah Cup.lbrn2 (49.1 KB)

I can’t correlate the g-code to the .lbrn file. What does Preview show you? Can you take a screenshot?



It looks fine on my screen and in preview, but cut very wide and with vertical lines, not filled in.

Avery Cup 3.txt (3.3 KB)

Avery Cup 3.lbrn2 (42.6 KB)

Here is the G-Code again. and the Lightburn File.

When you’re running the job and saving the g-code, do you have all the relevant elements selected?

For some reason it looks like only the oval is being saved in g-code.

The oval was the only thing I was cutting. I was making a test cut before cutting the rest. Previously I cut something else and it had the same effect, it was wide with vertical lines.

I don’t see any reason why the gcode would be generated that way from what’s available.

Can you take a full screenshot of LightBurn with the design loaded?